powered by Jive Software

Is this the expected response on a XEP-313 (urn:xmpp:mam:1) query with no existing data?

I’m starting to migrate a client to start using XEP-313. I’m using Openfire 4.1.3. In the client, I’m using the iOS XMPPFramework, using the XMPPMessageArchiveManagement module to generate the query.

Here’s what ends up getting sent:

<?xml version="1.0" encoding="UTF-8"?>
<iq type="set" id="4D40A119-F724-4760-AF21-C3E6DD816FF9">
   <query xmlns="urn:xmpp:mam:1" queryid="E6166138-7D3D-4DF6-9075-356B1636B470">
      <x xmlns="jabber:x:data" type="submit">
         <field var="FORM_TYPE" type="hidden">
      <set xmlns="http://jabber.org/protocol/rsm">

And here’s the response:

<?xml version="1.0" encoding="UTF-8"?>
<iq xmlns="jabber:client" type="error" id="4D40A119-F724-4760-AF21-C3E6DD816FF9" to="97c704c33c2b48b0838145ca90bd2bbb@localhost/a3xpvau8lb">
   <error code="501" type="cancel">
      <feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" />

The monitoring plugin is enabled in the server. Debug logging is also enabled in the server. However, I wasn’t able to see anything in the log that relates to this. Looking at Openfire 4.1.3 (selected that tag in GitHub) source code, it seems that something should have been logged, at least at the Debug level. But I don’t see anything of what’s being logged in the source code.

Any help or guidance is very much appreciated, thanks in advance!

1 Like

Is archiving actually enabled? Simply installing the monitoring plugin doesn’t do this by default, i think - you’d need to explicitly enable storing message content.

This is in Spanish, but yes, everything is enabled. I’m not sure why that error at the top appears, but again I couldn’t see anything in the logs.