powered by Jive Software

Issue on connection TLSv1.2

hi,

I have trouble with using Openfire server with ZOM messenger.

Server 1 - Openfire 4.1.2 on ubuntu

Server 2 - ejabberd 17.03 on ubuntu

Client 1 - ZOM android

Client 2 - freelab messenger (it’s conversations messenger 1.13.8 version)

Client 3 - ZOM iOS

TEST 1) Connecting to Server 1 with,

Client 1 is fail, Client 2 is fail, Client 3 is success.

TEST 2) Connecting to Server 2 with,

Client 1 is success, Client 2 is success, Client 3 is success.

So, I thought some problem is in Openfire server and packet captured with wireshark sniffer to case T1 as (Server 1, Client 1) and T2 as (Server 1, Client 2).

Both T1 and T2 showed that ZOM and freelab messenger hang on when connecting is established and start using TLSv1.2 protocol.

Capture image attached. At end of list, it’s going hang. no more packets between Openfire and ZOM, freelab.

I have tested Server 2 with Client 1, they also used TLSv1.2 protocol and worked well.

I don’t know what the root cause is, Openfire or Client messenger ?

Need help. Thank you.

Strange.

Both conversations and zom-android worked well with Openfire 4.0.4 and 4.1.0.beta

After openfire 4.1.0 release, they didn’t work.

I have found same issue on this forum - Openfire 4.1.1 and Android Conversations didn’t work

It seems that root cause is not cleared.

Just return to older version is only workaround ?

Could you kindly try installing the ‘Non-SASL Authentication’ plugin for Openfire and test your clients again?

Hi Daryl Herzmann.

I tested with Openfire 4.1.3 which Non-SASL Authentication plugin installed.

And It still not work.

My conversations messenger works with Openfire 4.1.0.beta only.

Thanks.