Issue transferring users and groups from old openfire server version to a new one

Hi to all supporters of Openfire,

I would like to seek your kind assistance regarding my current issue. Our company is using Spark as a messenger between employees for years now and this was turn over to me by our former employee without any proper documentation. Today, January 08, 2015, I saw that there is a new update which is the openfire 3.9.3 and our current version is 3.7.1. What I did is I tried to download the update and installed it to our hive server. My current issue is whenever I used the 3.9.3 version all users and groups are no longer in the admin site but when I open and run the 3.7.1 version they are still available to that admin site.

Is there any possibility that I can transfer all the users and groups I have in the admin website of 3.7.1 to the admin website of 3.9.3?

Hoping for your kind response regarding this matter as I am only a new employee.


We should at least know how your users are configured. Do you pull them from Active Directory or are they created locally in Openfire. You can check this by trying to edit name or other info of the user in Admin Console. If AD is in use, then it won’t let you change them (read-only).

Hi wroot,

Whenever we create a new user and groups we go to the openfire web admin site. I’m just having issue to locate how to export those users and import them to the new server. I saw a plugin the user import eport plugin but it only runs to 3.9.0 servers. my current server is 3.7.1 and I would like to upgrade to 3.9.3 without entering all the users one by one.

Hoping you can help me with my issue.


I understand your problem, but import export plugin is not really a solution in your situation. So, from your saying i understand that you reate local users and groups in Admin Console. When you run the 3.9.3 installer on top of the 3.7.1 and then run openfire launcher, do you see lines ‘updating database scheme’ or similar? Did you stop Openfire before running the upgrade? Maybe you are running it as a service, so you have to stop the service first. What i want to say, upgrade should take care of the database update to the current version and your users and groups should be there. Update in your case is not happening for some reason and I’m trying to find out why. What operating system are you using?

Hi wroot,

Finally my issue was resolved. What I did is I copy all the the data on the embedded db folder of 3.7.1 to the embedded db of 3.9.3. When I run the openfire again and launch the admin all users are now at the server and all users are now can log in to their spark messaging app.

Thank you for giving time in answering my issue.