powered by Jive Software

Issue with Cross Domain Chat Allowed to Connect Setting

Hey there,

I am currently running an Openfire Server (version 4.0.3) in our Domain and trying to get it to talk to other openfire servers in another Domain. I have had our network engineers create firewall rules for the appropriate IP Address’s using port 5269. After doing that I still cant add services from the other domains. I have noticed on our openfire server that the “Allowed To Connect” Setting has no option selected. I select the “Anyone” option but after logging out and then logging back in, or if I go to another menu and then come back to the “Server To Server” screen it doesn’t retain that setting and goes back to having no options selected. I have tried restarting services etc and the setting is still not retained. Is this a bug or known issue? Has anyone else ever experienced this while trying to set up cross domain functionality?

Cheers

K-L3SS

What do you mean by '‘add services from the other domain’? How are you attempting to establish the server 2 server (s2s) connection? Also, please try this with a current release of Openfire 4.1.5.

As an aside, Openfire 4.2.0 will have an built in server 2 server connection debugging console, see OF-159

I will update openfire to 4.1.5 first as i’ve just read that 4.0.3, the version we are currently on has a bug with the Server 2 Server Connection page.