Issue with logging in to console v4.0.1

Hi all hopefully some one can help me. The server that had my OpenFire server hard a drive go down in its raid 5 after replacing the hard drive and letting it rebuild OpenFire would no longer start up. The Database resides on a separate server running on MS SQL. I have been wanting to move the OpenFire server any was as the server its on is very old. I downloaded version 4.0.1 and installed it to the same server that the DB is located on. During the set up at the part where you enter the admin password it would not take the current password. I reset the plain text password in sql to admin and set the encrypted password to null. this seemed to work as i was able to change the password on that screen and even verified in the db that the plain text password was set to null and that the encrypted password was now populated. Once i got to the admin console and tried to log in i received the error that the username or password was incorrect using what i had just changed it to. Also none of my clients would connect. I discovered that by setting a plain text password in the db for a user and setting the encrypted password to null would allow users to login. I tried this with the admin account but no luck. For some reason that i cannot figure out encrypted passwords do not seem to be working. So i can get users to login with plain text passwords but not the stored encrypted passwords already established, and i cannot get into the admin console even though i was able to reset the password for the admin account in the set up procedure. Any help would be appreciated.

Ok well never mind. I figured it out I had to add the below lines to the openfire.xml file to get it to work. Not sure why i had to explicitly set the admin account to be admin but its working now. So hooray. Now i just have to go update all the clients to the new server address. For what ever reason the stored encrypted passwords in the database will have to be re-entered as they still cannot login but re-setting the password in the console allows them to login so not sure what happened but its working now.


If some one would like to chime in on why the stored encrypted passwords no longer work that would be super awesome.