powered by Jive Software

Issue with mysql database backend can't get openfire to connect

I created a database for openfire and created a user.

I even imported the database schema

mysql -p -u open openfire </opt/openfire/resources/database/openfire_mysql.sql

THAT WORKS eg…

mysql>use openfire;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> show tables;
±---------------------+
| Tables_in_openfire |
±---------------------+
| ofExtComponentConf |
| ofGroup |
| ofGroupProp |
| ofGroupUser |
| ofID |
| ofMucAffiliation |
| ofMucConversationLog |
| ofMucMember |
| ofMucRoom |
| ofMucRoomProp |
| ofMucService |
| ofMucServiceProp |
| ofOffline |
| ofPresence |

-------------------------------- CUT

I can NOT get the openfire installer to actually use it,

“A connection to the database could not be made. View the error message by opening the “/logs/error.log” log file, then go back to fix the problem.”

com.mysql.jdbc.Driver

jdbc:mysql://localhost:3306/openfire

I’ve tried,

  • jdbc:mysql://localhost/openfire

  • jdbc:mysql://192.168.1.110:3306/openfire ( and enabled remote mysql )

  • Using root login, even creating a new user. NOTHING WORKS WHAT GIVES???

I had an earlier version of openfire setup and didn’t have any issues. I tried the embedded database but it would not set the admin password, and the default passwd “admin” would’t work (seprate issue) but still. This is a fresh default centos install, with the latest version of openfire downloaded, and it should be straight forward.

lsof -i -n -P | grep mysql
mysqld 17713 mysql 10u IPv4 361724 TCP 192.168.1.110:3306 (LISTEN)

http://pastebin.com/m45be2fc — log output

is the port blocked? did you give rights to the database to the various users?

well its localhost, but iptables in not running, and selinux is permissive so its not something silly… its not blocked. I’ve tried it as root as well.

I can login via cmd line as both root and openfire, I imported the database schema as openfire user just fine.

It sounds like a port issue. Try to telnet to the port from the machine.