powered by Jive Software

Issue with Resource Policy

We are having some problems with Resource Policy on an Openfire 3.3.1 server install on Windows using AD for authentication. We have this same exact setup on an old Wildfire 3.0.0 server which is currently servicing our production environment. The plan is to upgrade to Openfire 3.3.1. To test things out first, though, I did a new Openfire install in a test environment. All seems to work pretty well except or Resource Policy.

We have the “Always kick” policy setup on both our old Wildfire server and on this new test server. It works right on our Wildfire server. When a person logs in somewhere else, their first connection gets the boot. On Openfire, though, the old connection stays connected. It doesn’‘t matter if I choose “Always kick”, or “Never kicks” – two of the same account can get on at once. I’'ve tried to compare settings bit for bit between both servers and they are identical where applicable. Can anyone help me figure out why Resource Policy is not working properly on Openfire, but it is on Wildfire?

Hi,

are both accounts using the same resource like “spark”?

Do you see the same account two times in the web admin console or only one time? Also there the resource is displayed. You can check this on https://server:9091/session-summary.jsp

LG

You know, I don’‘t know what’‘s going on now. The resource is in fact different, but I don’'t know why. We are using the Pandion client in all cases for our tests. If I connect from one machine with Pandion to our main Wildfire production server, then try to do it again from another machine to the same Wildfire server, the resource policy works right because it shows the resource as Pandion for both instances.

However, if I try to do the exact same test above to our test Openfire server, both can get on because one will connect and show the resource as Pandion, the other will show some 8 digit hash that looks like hex values. It’'s very bizarre. Any clues what I might look into to figure out why it works right on Wildfire with the resource name, but not with the current version of Openfire? All things are constant on the clients except for choosing which server to connect to.

Hi,

I tried this with Spark and there the logged in account is kicked. Can you try this with Spark?

LG

It may be something Pandion does to automatically recover when booted due to a resource conflict.

AWenckus: that doesn’'t explain why Pandion works right with Wildfire 3.0.0, though. The resource policy with kicking and such works fine in Wildfire, and only one instance can be logged in–both clients being Pandion. Something has definitely changed between Openfire and Wildfire in how it handles resources as Pandion is a constant in testing out both of these.

it2000: I will give that a shot when I get a chance, but we won’'t be able to use Spark as our solution (this will only be for testing purposes).

I don’‘t know what to think. I tried out Spark and it works fine with regards to doing the appropriate thing with Resource Policy. I guess I’‘ll stick with using this old 3.0 version of Wildfire because Pandion works properly with it, but not the new one. Saddly, Pandion is the only client out there that really fits our needs, but the lousy thing isn’'t developed anymore. That leaves me out of luck. Oh well.