Issues Migrating Openfire to Windows 7 x64

I am trying to migrate Openfire from Windows XP to Windows 7 x64. After reading various posts on migration, I copied the Openfire from the old installation to C:\Program Files (x86). Then I ran the installation. When it first completes and launches Openfire, I can launch the Admin Console, log in, and all of my user information, etc. is there. I can even access the admin console from another machine on the network. However, Spark will not launch. If I reboot the Windows 7 machine and try to relaunch the Admin Console, I get the “Internet Explorer cannot display this webpage” message. Does anyone know what I’m doing wrong? Thanks!

have you set openfire to run as a service? other wise, you’ll have to restart it after a reboot. Also, try disabling uac to address the other issue.

speedy, Thanks for your reply, and I apologize for not posting the resolution sooner. The issue did have to do with running Openfire as a service. I did more searching on the forum and found out that I needed to make a registry change to create the service, as the .exe would not do it. Here’s the link: Once I did this, I reinstalled Openfire and then copied over the embedded db folder. That worked! Thanks again for your input!

you would be wise to use an external database like ms sql express instead of the embeded-db. It can be installed on the same box with no problem, and ms sql express is free, so there are no additional cost.

Please let me know the reason for your advice.

the reason for me were mostly stablity, expandablity, ease of accessing the data. I’m sure there are some performance improvements for using an external database as well.