powered by Jive Software

Issues Openfire 3.7.0

Hi all,

I tried to install the openfire 3.7.0 beta, everything is fine but red5, kraken gateway plugin. After install red5, kraken plugin, nothing happen.

Regards,

Alex

What do you mean by “nothing happen”? It is known, that Kraken stops working, well actually Spark can’t see gateways anymore (probably same with other clients), with Openfire 3.7.0 version. This is Kraken issue with new Openfire’s logging system, probably. Guus is working with Daniel (Kraken’s author) to fix that. So far i recommend to get back to 3.6.4 and wait for Kraken’s update. Can’t tell anything about the Red5. Try asking in Red5 forum’s section.

All plugins which are not in SVN may have problems running within 3.7.0 as there log4j is used for logging.

@Red5 - You could try to use Redfire instead of Openfire.

I had to uninstall the zapcat monitoring plugin:

http://www.kjkoster.org/zapcat/Openfire_How_To.html

until I did, openfire 3.7.0b was not listening for connections

Another issue found. The rpm package overwrited /etc/init.d/openfire, which I customized.

Usually, the init scripts in other packages are declared as config files so are not overwritten (they are saved as .rpmnew)

Thanks, filed OF-396 for the RPM issue

hi, all!

I have some strange problem with Openfire 3.7.0 beta (it actually started with some nightly build after openfire_2010-07-28). I run windows version installed as a service, my clients are Miranda IM Jabber Unicode 0.9.3.3.

After installing Openfire 3.7.0 beta almost all service names except for pubsub and proxy (as seen at “service discovery” Miranda window) get prepended with “null@” - e.g. “broadcast.server” becomes “null@broacast.server” etc. Two of these “null@” services are marked with a “red cross sign” and show “Info request error: Error 404: Not found” as node information. As a result i can’t, for example, expand “broadcast” to see broadcast groups.

Except for the behaviour described above all services are actually functioning normally (broadcast messages are actually sent). I also get this at error.log (i use LDAP users and groups):

org.jivesoftware.openfire.group.GroupNotFoundException: Groupname null not found

What could be the reason for that? Should i change some setting or this is some bug?

Any help is appreciated. Thanks in advance.

<iq id="koRB4-2" to="igniterealtime.org" type="get">
  <query xmlns="http://jabber.org/protocol/disco#items"/>
</iq> <iq id="koRB4-2" to="lg@igniterealtime.org/home" from="igniterealtime.org" type="result">
  <query xmlns="http://jabber.org/protocol/disco#items">
    <item jid="pubsub.igniterealtime.org" name="Publish-Subscribe service"/>
    <item jid="null@clearspace.igniterealtime.org" name="Clearspace"/>
    <item jid="null@conference.igniterealtime.org" name="Public Chatrooms"/>
    <item jid="proxy.igniterealtime.org" name="Socks 5 Bytestreams Proxy"/>
    <item jid="conference.igniterealtime.org" name="Public Chatrooms"/>
    <item jid="null@search.igniterealtime.org" name="User Search"/>
  </query>
</iq>

this does not look good

i have i same problemm!

after upgrade to Openfire 3.7.0 Beta all my services have prefix null@ and don’t work!

OF-420

fwiw, I just figured out and resolved the logging issue with Kraken. Turned out Kraken was trying to take over “all log4j logging”. =/ (due to my misunderstanding of how some things in log4j worked) That said – any chance y’all can push out a new beta with this update asap? I ask because I’m about to put out a Kraken 1.1.3 beta 2 that has the fix in it, and would ideally like to point folk at an actual openfire beta release instead of “download from nightlies”.

Hi Daniel,

Good to hear from you! I am confused though. So you fixed something with openfire trunk?

daryl

Hi Daryl! No – I fixed the issue in Kraken. =) BUT Kraken doesn’t work at all with OF-420 outstanding. That’s broken in the beta release, but fixed in trunk.

Thank you, I am no longer confused. I’m gonna yell at Guus and see if we can’t just get 3.7.0 out the door.

Yeah, I tried this with zapcat today too and noticed it makes trunk openfire unstable. Investigating