Issues Setting up 3.7.1

i had 3.7.0 working fine and it has been sometime since i accessed the admin panel

now since i could not remember the pw i followed instructions to reset it by changing the setup to false in the openfire.xml located in the opt/openfire/conf folder which worked ok

i went back to the web panel and reset the admin pw but it had no effect…i could not access it at all

so i rm -r /opt/openfire and downloaded the 3.7.1 tar.gz version directly from this website

following the same instructions i followed to setup the previous version everything goes fine however there is no openfire executable like before only a and openfire.bat

if i try ./ i get permission denied

if i try service openfire start i get a javahome error

please help me as everything was wrking fine before i tried to upgrade and im a linux noob relying mostly on google to learn ^^

ive rolled back to version 3.7.0 and it is working ok

i then installed 3.7.1 over the top of 3.7.0 and then rebooted the system and its now working and upgraded \o/

some better installation instructions (or easier found because i could not find any) should be made available for us noobs out here who are still learning this stuff

i hope this helps anyone else like me having this issue as i spent hours poking around trying to fix it