Issues w/ running Openfire as a service on Windows 2k3

I followed the steps for adding the Openfire service as suggested on the Windows startup guide. The service is installed and appears to be running, though I am unable to connect to the server. Everything works fine if I start the server application, but I’d like to be able to have the service running so as to avoid having an extra user logged on all the time. Anyone know of any tricks I can try to make the service connect? Any help would be greatly appreciated.



quit the running application before starting the service. maybe even do a reboot of the server since it starts automatically. test it then.

I’ve tried this, but the service will still not allow people to log in. Are there any other configuration options, etc. I might need to work with before the service can run?

If the Windows firewall is running, are the correct ports open ? Have you tried to telnet onto 5222, 5223, 9090 and 9091 from the local server ?

All of those ports are currently open on the server. I’m thinking we’ll likely just leave the OF application running on the server’s admin account for the time being. I may try setting up the services again when everyone goes home today. If anyone has any other suggestions, I’m all ears.

Thanks again for helping me out, by the by.

are the ports open for the service specifically? or are they open for openfire.exe.

I’m just bumping this in case someone has resolved this.

I’m running Openfire on a W2K3 VM. Whenever the VM is restarted the service restarts but refuses logins from Spark (admin console does accept logins) - I have to either restart the service or run the application from the admin account before it accepts logins. Lately I’ve had to try both alternatives a couple of times before it gets its act together.

It always displays this behaviour after a machine restart.


I still have this problem, but it one of my bi-annual hunts to see if anyone has figured it out I picked up a tip.


netstat -an

to see what ports are open on the server, and their status

I notice that while it’s refusing connections there are a number of ports for the clients open and sitting in ‘TIME_WAIT’ mode - I’m wondering if that’s because I have hung client/server sessions that Spark is trying to reopen. I tried restarting the server and the service (ten times) but for the first time that didn’t work - so I waited until after closing when there shouldn’t be any Spark clients running, stopped the service, waited five minutes, started the service, and it’s back to normal.

Coincidence or a clue?

I believe it might be a bug as i have the same issue, the Openfire server 3.7 is installed on a windows 2008 server, and the openfire service has been installed, the service starts automatically, it however does not accept connections until the it is the openfire service is restarted.