powered by Jive Software

Issues w/ setup-admin-settings.jsp

After setting up the Language Selection (english), Server Settings, Database Settings (oracle) and Profile Settings (LDAP/AD) I click the save and continue button on the “Profile Settings: Group Mapping” page and I am confronted with the following and I have no idea what to do from this point:

HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/setup/setup-admin-settings.jsp

Caused by:

java.lang.NullPointerException
 at org.jivesoftware.openfire.admin.setup.setup_002dadmin_002dsettings_jsp._jspService(setup_002dadmin_002dsettings_jsp.java:99)
 at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
 at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
 at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
 at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
 at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
 at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:42)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
 at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
 at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
 at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
 at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
 at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
 at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
 at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
 at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
 at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
 at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
 at org.mortbay.jetty.Server.handle(Server.java:324)
 at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
 at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
 at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
 at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
 at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
 at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
 at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Powered by Jetty://

Hi,

does “Make sure that the unix command “hostname” returns a valid name, for example “example.com” and that your /etc/hosts file does contain this name, for example in the first line together with “127.0.0.1 localhost example.com”. Or that you can resolve it using DNS. Actually the setup page after choosing your locale settings will return a HTTP 500 error if there is a problem.” help you?

LG

Who said this is on Unix? In fact with an ActiveDirectory integration it is safer to assume it it on a Windows Server. I have the same error on Windows Server 2003. The DC is not the same computer as I am running the openfire server from however the DC is definetely defined in DNS.

I have this same issue as well

on Win Server 2008

What I eventually did to get this to work was I renamed the xml settings file and continued setup. The settings get saved to cookies anyways so the webpage will re-create the xml file from scratch and it should work.

Hi,

I have this issue, too. The solution provided here don’t work, can you help me?

Technically:

I’m running the openfire 3.3.6 server on Debian stable, java6, using the internel DB engine (not any MySQL or whatever).

I’ve just installed it and launched the configuration. With the help of sysinternals’s AD explorer, I managed to write the correct settings in my AD configuration.

What I’ve tried:

“hostname” gives my short name, let’s call it “something”

“hostname --fqdn” gives the right name “something.company.local” because I modified /etc/hosts

“dnsdomainname” gives “company.local”

==> What can I do?

I don’t have any settings.xml, only an almost empty /etc/openfire/openfire.xml that comes with the package installation.

For BryanSix: I’m connecting to a windows AD - that makes sense: your internal computer landscape might be running Microsoft’s environments, so an AD is handy ; but some other services might be on Linux boxes. So does Jabber

Thank you for your help

I just rebooted and restarted the configuration from scratch.

It worked…great

1 Like

Hey all, I faced the exact situation. Running Windows Server 2008 Standard, 64 bit.

As you adviced, the problem is “solved” after reboot.

Maybe a force reboot after installation on Windows is needed…

Thanks.

Angus

Hi everyone,

It looks you are taking too long to setup openfire and the session is expiring causing the lost of parameters.

Solution: restart openfire service, close setup webpage and access it again. Be faster configuring this time.

It really works, just reboot it

Apologies for re-opening many old conversations but…
This comes up in google search results and this error continues to show up. There is a solution posted on one of the results but people keep hitting the same thing.

The solution is to go back to the server page. Either the XMPP Domain Name or the FQDN is wrong. Mine had defaulted to machine.local_lan.int for both. It should have been :
XMPP Domain: local_lan.int
XMPP FQDN: machine.local_lan.int
Someone could put a try/catch around the line generating this and inform people that it is their server settings. Instead it suggests that this is caused by a cookie problem and to try clearing history or using an incognito tab.