powered by Jive Software

JapPix not allowing logins

Hi Everyone,

I am trying to install, and setup JapPix for the first time on Openfire 3.7.1. I have installed the plugin version using the .war file located on this link: [http://code.google.com/p/openfire-jappix/downloads/list](http://code.google.com/p/openfire-jappix/downloads/list). After the installation, I logged into the page using the [http://www.domain.com:7070/jappix](http://www.domain.com:7070/jappix) link, this lauched a setup wizared, so I went through the step-by-step, and tried to login. But I only get an error that says **Error: Authorization failed**. After looking at my debug logs, I found this:

2012.10.26 00:07:54 org.jivesoftware.util.log.util.JettyLog - JettyLog: return with suspended request

2012.10.26 00:07:54 org.jivesoftware.openfire.net.SASLAuthentication - SASLAuthentication: SaslException

javax.security.sasl.SaslException: DIGEST-MD5: digest response format violation. Nonexistent realm: domain.com

at com.sun.security.sasl.digest.DigestMD5Server.validateClientResponse(Unknown Source)

at com.sun.security.sasl.digest.DigestMD5Server.evaluateResponse(Unknown Source)

at org.jivesoftware.openfire.net.SASLAuthentication.handle(SASLAuthentication.java :325)

at org.jivesoftware.openfire.SessionPacketRouter.route(SessionPacketRouter.java:66 )

at org.jivesoftware.openfire.http.HttpSession.sendPendingPackets(HttpSession.java: 636)

at org.jivesoftware.openfire.http.HttpSessionManager$HttpPacketSender.run(HttpSess ionManager.java:390)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

I am also noticing that the manger page will not let me login with the admin username and password I created.

Any input would be great.

Thanks,

Rafael

I been doing more troubleshooting, but I am not any closer to finding out what is going on. I am also noticing that the admin password I set for the manager is not working. Any one has any clue what I am missing? I am trying a default setup using the plugin.

Thanks,

Rafael

Have you tried to log in from other openfire server that also has installed jappix? for example http://mayplaces.com/im which support S2S bosh connection, to check whether you installed your server correctly or not

Thanks for the reply aRyo S. I tried the website you recommneded, but I am still getting the same messsage: “Error Authorization failed”. What does that mean? Do I need to register the program? Or did I miss something on the configuration? I can post what ever is needed.

Thanks,

Rafael

Authorization fails it means your server can’t accept the authentication(SASL, based on your logs) method OR you have been using the wrong login information. On your case it is very difficult to know what is wrong without trying it directly.

I am trying to get JapPix to authenticate using http-bind on port 7070. Is that not the default? Or does it use something else? I don’t see why it was use SASL authentication if I want it to authenticate using http-bind using my openfire server. Any thoughts?

Thanks again for your help aRyo S.

Rafael

I tried this install about 15 differant time, and I am noticing that the JapPix Plugin is ignoring the configuration I place on the setup stage of the install. I tried modifiying the configuration file manuelly, but that produced the same result. I am still not able to connect to my openfire server using the JapPix client.

Rafael

Any update on this issue? I am having exactly the same issue with Openfire 3.8.2 and jappix 0.0.0.6.

I had this issue, I was finally able to login after using all default values and enabling the built-in bosh checkbox.

Also be sure you’re using the domain name and not the IP address.

Good luck,

J

1 Like

Changing the domain name from the IP address fixed the issue for me