powered by Jive Software

Java and Openfire

I hope this is the best place to post this. I’ve installed Openfire/Spark many times without issue. It’s been about a year since the last time. I’ve always done it the same way; Download Java, Install java. Download Openfire,install openfire. I have a fresh VM with Java installed and yet the openfire installer gives me an error that it cannot locate JRE. I’ve tried this on multiple machines, I’ve read my error logs, I’ve googled. I get it, “locate java”. But when I do locate JRE, I get an error saying that java.exe is damaged.

Reading the log, it seems like the installer DOES find JRE.

[531:305] LoadDLL (1, C:\Program Files (x86)\Java\jre1.8.0_311\bin\java.exe, 1)
[531:462] Got JRE location C:\Program Files (x86)\Java\jre1.8.0_311\bin\java.exe (java exe: 1)

but then I get

[532:831] Trying to load JVM-DLL from c:\program files (x86)\java\jre1.8.0_311\bin\java.exe
[532:847] Adding DLL directory c:\program files (x86)\java\jre1.8.0_311\bin
[532:847] Setting PATH 302 c:\program files (x86)\java\jre1.8.0_311\bin;C:\Users\haxor\AppData\Local\Temp\e4jAD5.tmp_dir1642019577\user;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Users\haxor\AppData\Local\Microsoft\WindowsApps;
[532:863] Trying c:\program files (x86)\java\jre1.8.0_311\bin\server\jvm.dll (exists 0)
[532:878] Trying c:\program files (x86)\java\jre1.8.0_311\bin\client\jvm.dll (exists 1)
[532:894] Failed with error code 193

and then finally

[533:50] ERROR: Could not get DLL-Handle.
[533:50] ERROR: Could not load functions

I don’t post online often for support so hopefully, my formatting and explanation is correct. Thank you for your time.

Which Openfire version are you trying to install?
Is this a newly built server? What’s the Windows version? Have you tried Java 11?

There is no “Java 11” at the moment. Highest version is 8. Not my answer, go ask Oracle.

Also: Trying to install 4.7 Openfire on a server 2012 machine.

Installer insists it can’t detect a JRE, so I went and installed one (8.33), then pointed the installer at it.

Installer says it’s “damaged”.

I understand they don’t distribute with JRE anymore (as with previous versions), but it also seems like the installer can’t work with a separately installed JRE either, so… not great.

Unsure what you mean by “There is no Java 11”. Java 18 came out recently. Java Downloads | Oracle

We don’t ship the JRE any more because the release cadence of Java (mostly security fixes) is higher than the release cadence of Openfire.

I’d take a look at getting a more up to date JRE from Adoptium - Latest releases

This is probably because Java 8 is still mainstream and most apps require it, so Oracle suggests it on java.com download page. But Oracle has since released many versions (9/10/11/12…18). 8/11/17 are Long Term Support versions. There are ways to download Oracle Java newer than 8, but OpenJDK should work as well. Like RedHat/Amazon or above suggested Adoptium.