powered by Jive Software

Java Error

Greetings,

I’m receiving the following error occasionally:

An unexpected error has been detected by Java Runtime Environment:

java.lang.OutOfMemoryError: requested 32776 bytes for Chunk::new. Out of swap space?

Internal Error (414C4C4F434154494F4E0E43505000C7), pid=3472, tid=5888

Java VM: Java HotSpot™ Server VM (1.6.0_03-b05 mixed mode)

An error report file with more information is saved as hs_err_pid3472.log

If you would like to submit a bug report, please visit:

http://java.sun.com/webapps/bugreport/crash.jsp

It doesn’t happen all the time and I can Stop and Start the Openfire Service with no problem. Thanks for all your help, in advance!!

What’s the scale of your Openfire Install (# simultaneous users)?

How much RAM have you allotted the Openfire VM instance?

Thanks

Thanks very much for your reply.

At maximum, we probably have 30-40 users on simultaeneous users on Spark.

How would I find out how much RAM is allotted? I could tell you how much ram is on the server, but I doubt that would answer the question.

Thanks again,

This thread has a walk-through:

http://www.igniterealtime.org/community/thread/36444

Hi,

you may want to use the Task Manager and take a look at the column “virtual memory”.

You may want to update the JRE to 1.6.0_12. If the JRE is located in the Openfire directory then you may want to install the JRE on another computer and then copy the JRE 160_12 directory into the Openfire folder. There may be native memory issues within the JRE which may be fixed with a new version.

LG

Hi,

Virtual memory high open fire, help! (36444) has nothing to do with this JVM error.

LG

Thanks for the help, LG.

I’m very new to Openfire and also to JRE, could it explain it further? What file am I looking for in the Openfire directory?

Thanks in advance,

Hi,

is this a windows or a linux server? This error seems to be caused by a native outofmemory, so you may verify how much free memory you have. Is this a physical server or a VPS?

LG

Has this issue been resolved? I am having the identical problems right down to the internal error code… The service will run for a day, maybe two, then it will stop with the error message below.

We are running Openfire 3.6.4 w/ the bundled version of JRE

Windows Server 2003 SP2 (Virtual Server in VMware ESX)

Dual 2.3Ghz Procs / 2GB of RAM

-Xms1024m -Xmx1024m (You can see all arguments in the error msg below. We tried 256/256, 512/512 and 512/1024 as recommended in the linked article…same problems)

Plugins:

Client Control: Only allow Spark client

Content Filter: Currently Disabled - Possible future use

Kraken IM Gateway: We control IM Gateway access through groups. Only 160 users are allowed to used it.

Monitoring Service: Full archiving is enabled. User to User and group chats

Red5: Used for video conferencing test (3 users) and where JWCHAT is setup . HTTP Binding is enabled for this.

Search: Used for easy searching…duh

User Import Export: Used for migration of user from old IM solution

User Service: Currently Disabled - Possible futre use

We have 3000 accounts w/ a max of 1500 concurrent users. We average 1100 to 1200 concurrent users.

Running SQL 2005 DB (on a dedicated SQL server)

Microsoft SQL Server Management Studio 9.00.4035.00
Microsoft Analysis Services Client Tools 2005.090.4035.00
Microsoft Data Access Components (MDAC) 2000.086.3959.00 (srv03_sp2_rtm.070216-1710)
Microsoft MSXML 2.6 3.0 6.0
Microsoft Internet Explorer 7.0.5730.13
Microsoft .NET Framework 2.0.50727.3082
Operating System 5.2.3790

Error Message…I excluded the process list due to length. If this will help, I can post it. If anyone has a solution, I am in desperate need of help. Everything worked great during our testing of 400-500 concurrent users.

An unexpected error has been detected by Java Runtime Environment:

java.lang.OutOfMemoryError: requested 835968 bytes for Chunk::new. Out of swap space?

Internal Error (414C4C4F434154494F4E0E43505000C7), pid=3188, tid=3168

Java VM: Java HotSpot™ Server VM (1.6.0_03-b05 mixed mode)

If you would like to submit a bug report, please visit:

http://java.sun.com/webapps/bugreport/crash.jsp

--------------- T H R E A D ---------------

Current thread (0x4801f800): JavaThread “CompilerThread1” daemon [_thread_in_native, id=3168]

Stack: [0x483b0000,0x48400000)
[error occurred during error reporting, step 110, id 0xc0000005]

Current CompileTask:
C2:2692 org.jivesoftware.openfire.plugin.SearchPlugin.replyDataFormResult(Ljava/util/Co llection;Lorg/xmpp/packet/IQ;)Lorg/xmpp/packet/IQ; (416 bytes)

VM Arguments:
jvm_args: -Dexe4j.isInstall4j=true -Dexe4j.isService=true -Dexe4j.moduleName=C:\Program Files\Openfire\bin\openfire-service.exe -Dexe4j.processCommFile=C:\WINDOWS\TEMP\e4j_p3188.tmp -Dexe4j.tempDir= -Dexe4j.unextractedPosition=0 -Dexe4j.consoleCodepage=cp0 -Xrs -Xms1024m -Xmx1024m
java_command:
Launcher Type: generic

Environment Variables:
PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\program files\openfire\jre\bin
OS=Windows_NT
PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 8, GenuineIntel

--------------- S Y S T E M ---------------

OS: Windows Server 2003 family Build 3790 Service Pack 2

CPU:total 2 (4 cores per cpu, 1 threads per core) family 6 model 15 stepping 7, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3

Memory: 4k page, physical 2096584k(1255816k free), swap 4194303k(4194303k free)

vm_info: Java HotSpot™ Server VM (1.6.0_03-b05) for windows-x86, built on Sep 24 2007 22:20:35 by “java_re” with unknown MS VC++:1310