powered by Jive Software

Java Memory

Hi,

I have the same problem. my memory is restricted to 64MB, its wildfire 3.1.1 on CentoOS 4. i have created a vmoptions file in /opt/wildfire/bin/ as

-Xms256m

-Xmx512m

Environment

JVM Version and Vendor: 1.5.0_08 Sun Microsystems Inc. – Java HotSpot™ Server VM

Appserver: Jetty/5.1.x

OS / Hardware: Linux / i386

Locale / Timezone: en / India Standard Time (5 GMT)

Java Memory 61.41 MB of 63.31 MB (97.0%) used

and kicks all the users. please help me what to do.

Swapnil

I just had the same issues. In the wildfire.xml file, set Java holds the LDAP connections open for up to 15 minutes and will cause you to run out of memory quickly…

on your Xms and Xmx how can you set them to 256 and 512 if you are restricted to 64MB ?

instead of adding a vmoptions file, you can instead add the params in the bin/wildfire executable…

Jeff

Message was edited by: jeff_garner

by saying "restricted to 64MB " i mean it shows me java mem 64mb in Server Settings.

i have 1 GB of ram but i am not able to use it. how do i increase the memory

swapnil

In the wildfire executable (opt/wildfire/bin/wildfire) place the “-Xms=256m -Xmx=512m” after the VM params section (I think it is the fourth entry from the top) you don;t have to use the vmoptions under Linux, I believe that is more for the Windows environment…

restart the wildfire server, and you should now see the 512MB as your max memory…

Jeff

(I am logging for the night, will check on this thread in the morning to see if it worked for you.(US CST) )

well that didn’'t work

i changed vmoptions_file option to point to my vmoptions file in the bin/wildfire file and that worked

thanks a lot

swapnil

Great, good to hear that it is now working for you!

This is my setting in the wildfire excuting file,but the things are not happy.My memory has been exhausted and I can not do anything else then.

  1. Uncomment the following line to add additional VM parameters

INSTALL4J_ADD_VM_PARAMS="-Xms25m -Xmx300m"

Something happed like this:

netstat -an | grep 9090

-bash: fork: Cannot allocate memory

free -m

-bash: fork: Cannot allocate memory

David. You have three threads running at the same time for a similiar issue.

Describe what sort of machine you are running, and specs for it. processors, total memory, Distro you have installed, disk space…

There is no need to edit the /opt/wildfire/bin/wildfire script, simply name your configuration file wildfire.vmoptions and place the file in /opt/wildfire/bin/

The contents of the file should be:

-Xms64m

-Xmx128m

(Use any memory size in place of 64 and 128 above)

Then restart wildfire

How would I do this for Openfire 3.3.1 for windows?

Hi,

on http://www.igniterealtime.org/downloads/index.jsp is an Openfire link which links to a page which contains a link to the and on the “Documentation” page is another link to the . And this guide contains the new file names one must use on Windows.

Is it really so hard to read the documentation which answers such basic questions?

LG

I did read it but I somehow missed the name openfire-service.vmoptions for the service settings file. I was using openfired.vmoptions. Sorry to offend you. Just guess i have to read better before i ask a question so I do not get flamed.

Hi,

I wonder sometimes if this documentation is just too long so one may miss interesting facts. There are only a few special things in it like the names and describing how to use these things may help the users who have a lot of time but if one is in a hurry a short overview would be much better. This could be something for the wiki …

LG