powered by Jive Software

Java Memory

Currently have 64MB allocated (according to console), we aren’t even using across the board yet, hardly a full department. How do we raise this? The discussions I’ve found about this don’t seem to work for us.

CentOS 4.5

Openfire 3.5.2

Environment
Java Version:
1.6.0_03 Sun Microsystems Inc. – Java HotSpot™ Server VM
Appserver:
jetty-6.1.x
Host Name:
pc-openfire01.pnc.pridgeonandclay.com
OS / Hardware:
Linux / i386
Locale / Timezone:
en / Eastern Standard Time (-5 GMT)
Java Memory

37.30 MB of 63.31 MB (58.9%) used

The memory usage rises and falls (since it is lunch time it is lower…), it seems to be around 80-90% during the work times.

From the install guide:

Custom Parameters

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Openfire. If you installed via RPM, you can customize this by editing /etc/sysconfig/openfire and looking at the OPENFIRE_OPTS option. If you installed via .tar.gz, you will need to tweak your startup script to fit your needs.

sixthring wrote:

From the install guide:

Custom Parameters

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Openfire. If you installed via RPM, you can customize this by editing /etc/sysconfig/openfire and looking at the OPENFIRE_OPTS option. If you installed via .tar.gz, you will need to tweak your startup script to fit your needs.

That would be great, except, I do not have that location.

/etc/sysconfig/openfire
I know I installed by RPM.

That’s weird, I’ve got three of these servers running at the moment, all installed by RPM on Red Hat EL, and they all have the openfire file in /etc/sysconfig. Can you do a search from root for files containing OPENFIRE_OPTS maybe, to see if it’s hiding somewhere else? The startup script would tell you as well I would think. Or maybe just create it in the proper location - I can send you a copy of my file for reference if you like.

Nick

PS - this is definitely what you need to do to increase the Java memory BTW, so once you track down the file it will solve your problem.

hmm. For some reason it isn’t on my test box, but is indeed on my live server.

anyway… lets see how to bre… I mean make it better

Java Memory


8.85 MB of 1012.62 MB (0.9%) used

That makes me feel better

Hello

How did you increase your Java memory?

I’ve installed fom deb in an Ubuntu and i haven’t /etc/sysconfig

ITs the same for me. Dont have that folder in my installation. Ubuntu 9.04 server installed from RPM

This thread solved my problem.

http://www.igniterealtime.org/community/thread/40364