powered by Jive Software

JID - doesn't support Socks5 bytestream

Hi,

I use Smack library in an Android project and everything worked fine until I get to the file transfer.

We need to use XEP-0065 so I use the Socks5Bytestream classes.

When I make the call: Socks5BytestreamSession session = socks5BytestreamManager.establishSession(toJID);

I get the XMPPException that tell me that the friend doesn’t support Socks5 Bytestream, but when I get the disco#info from that friend I receive the feature: http://jabber.org/protocol/bytestreams

that was added with: serviceDiscoMgr.addFeature(“http://jabber.org/protocol/bytestreams”);

Any help on this will be useful.

Thanks

Do you call establishSession() or do you let smack call it for you when using the file transfer API? Also you shouldn’t need to manually add features, that is done automatically.

Given the current information from you, I can only point to this page: https://github.com/Flowdalic/asmack/wiki/aSmack-XMPP-File-Transfer

Hi,

Thanks for your answer.

The problem was that I made the call with the JID and not the full JID (with the instance).

Now it works!