powered by Jive Software

JID escaping

Tried the yesterday’'s build and this new feature works perfectly on my server. All the usernames with space are seen on the users list.

Now what username do I use for the client? Most of the jabber clients don’‘t support space on jid. I tried name+name like on the admin consol, but it doesn’'t work.

Do you know what client supports space in jid or what character do I use instead of space.

Thanks and keep up the excellent work.

PS. Plug-ins don’'t work with the nightly builds?

I found answer myself for space it is \20 so lastname\20firstname, but it doesn’‘t authenticate right with Jive. I don’'t know is that implemented in May 16 version or still in development. Users without space authenticate OK.

This is a whole table

Unescaped Character Encoded Character

\20

" \22

& \26

‘’ \27

/ \2f

: \3a

< \3c

                                \3e

@ \40

\ \5c

We might need more escape handling for authentication with LDAP. Can you try escaping the space character with a ‘’’’? For example, if the name is “matt tucker”, use “matt\ tucker”. I’'ll try to get an LDAP instance setup for testing locally as well.

Regards,

Matt

Tried \ as well, doesn’'t work

I hope someone has figured this out. I am using 2.2 with LDAP (AD on 2003) with Miranda 0.4.0.1 and all of our usernames have a space in them (First Last). They show up on the user list in the Jive admin console, but I cannot login with any of them.

Patrick

I believe we’'ve finally fixed this for the 2.2.1 release, which should be out tomorrow.

-Matt