Jingle Nodes Plugin 3.0.0 with public ip

Hi All,

I have installed Openfire 3.8.2 with 2 plugin websocket and Jingle version 3.0.0.

I have made a web rtc based one to one audio~video call using websocket and jingle. The solution worked perfectly in local network.

Next I have deployed the seolution in a server with public ip. Now when cliecked the “Jinge Nodes” Tab Its whowing me setup as attached screen shot.

I tried to Override Public IP: with my public IP and pressed “update setting” no actio take.

I have asked my isp about the IP and they confirmed that is a public ip. I can access openfire using the ip over internet as well.

How to solve the issue? Is there any way to verify the IP is really public or not.

How to solve this? Any way to define the ip in jingle nodes?

Thanks! in advance for the cooperation.

Same problem here. This question really needs to be answered. By what process does the plugin decide that an IP address is public? I’ve had this on a Linux install on a public address and on a local install.

This walkthrough:


simply does not work.

The answer is to modify the code in jingleNodes as given in this thread:

Hello ,

the plugin was updated 3 days ago.

I’ve updated it also on my server but I still get the same error

"Jingle Nodes Requires a Public IP for Internet Calling. Public IP Found: none"

The UDP ports are open but still, the plugin doesn’t seem to work.

Any ideas?