Jingle Nodes Problems

Some problems with Jingle Nodes 0.0.3 in Openfire 3.7.1:

1] Question marks everywhere. I assume this is because of the already-reported missing language file

2] Configurable port range - “30000 to 50000” mentioned in the readme is much too large for my needs

3] Why the need to verify the IP address? The external IP is already correctly autodetected, and I’d imagine verifying it every time the address changes would be troublesome. Why not assume the STUN results are correct, or simply use the xmpp.domain DNS value?

question marks have been fixed since the report, at least it shows ok with English locale on my test server. Don’t know about the other issues.

Where do you get the version which fixes the question marks? The Jingle Nodes Plugin still shows as version 0.0.3 after updating the list of available plugins.

From the available plugins page. Do you use English locale?

My openfire locale is en (english) and my server locale is en_US.UTF-8. The available plugins page (after updating the list) show the latest Jingle Nodes Plugin as 0.0.3, and I just tried uninstalling/reinstalling it again.

By the way there seems to be an issue with deleting the jingle nodes plugin, where it seems to be automatically reinstalled, so I have to uninstall/delete it via the web interface, then delete the jingle node plugin files on the server manually. For the record, I am running on linux.

Well, i’m trying on WinXP. maybe that’s the difference. Can’t try it on linux right now.

Is the missing language file (causing all the question marks in the web interface) this:


Because it is present in my jingle nodes 0.0.3 plugin installation and I still have question marks

I built the plugin myself, question marks still everywhere…

Ok, it shows question marks for me too on my production server (linux). Don’t know why it works ok on WinXP Added a comment to http://issues.igniterealtime.org/browse/OF-444

On a hunch I renamed “jingleNodes_i18n.properties” to “jinglenodes_i18n.properties” and restarted openfire. There are now no question marks. Linux is case-sensitive, and windows is not. The Jingle Nodes Plugins provides org.jinglenodes namespace, so I suppose it was looking for a corresponding language file.

Now I can read properly the plugin features, and can answer some of my own questions:

1] solved

2] To change the port range, edit the source and rebuild the plugin. From what I can tell http://xmpp.org/extensions/xep-0278.html jingle nodes can use any port range.

3] Ignore this, it is autodetected, I misread the question marks.

Anyway, from what I can tell, this jingle nodes plugins provides both an XMPP relay (explains the “active channels” information field) and tracker. Which means, basically, plug and play: openfire media services should be disabled since jingle nodes provides a standalone relay, and clients do not need to manually add a list of jingle node relays, since they can just query the jingle nodes plugin.

Unfortunately, I have yet to get the Jingle Nodes Plugin to work…


Good catch i haven’t thought about the case sensitivity.

Newbie, Sorry for what might be a very obious question.

Using linux -

where in openfire admin console do I rename “jingleNodes_i18n.properties” to “jinglenodes_i18n.properties”?


Not in the console, this has to be changed in the jar itself. Open jinglenodes.jar file with the archiver, find jingleNodes_i18n.properties, rename it and then repack the jar.

1 Like


Has any one resolved this problem with openfire Jingle Node, yet please update?

Keke, this is resolved by unpacking the Jar file (you can use unzip), changing the name of jingleNodes_i18n.properties to jinglenodes_i18n.properties (No Upper Case N), and repacking the jar using the jar command ( jar -cf jinglenodes.jar -C jinglenodes ).

See Wroot’s post.

Linux (and nix in general)(ext/XFS/Reiser/etc…) care about case in file names. Windows(NTFS/FAT) does not.

1 Like

James, I have done what you said but still unable to enable configuration properly

Jingle Node still show this error message

* Jingle Nodes Requires a Public IP for Internet Calling. Public IP Found:* none

If some knows how to fix that please let me know**

me too,you can try to edit (final InetSocketAddress addr = PublicIPResolver.getPublicAddress(“stun.xten.com”, 3478)) to (final InetSocketAddress addr = PublicIPResolver.getPublicAddress(“stun.ekiga.net”, 3478):wink:

http://kaiser-im.googlecode.com/svn/trunk/openfire/work/plugins-dev/jingleNodes/ target/jspc/java/org/jivesoftware/openfire/plugin/jingleNodes/jingle_002dnodes_j sp.javahttp://kaiser-im.googlecode.com/svn/trunk/openfire/work/plugins-dev/jingleNodes/ target/jspc/java/org/jivesoftware/openfire/plugin/jingleNodes/jingle_002dnodes_j sp.java

I would like to know if any one have found a solution for audio/video conference for openfire (NAT)


do we still need to do that ?

Keke, this is resolved by unpacking the Jar file (you can use unzip), changing the name of jingleNodes_i18n.properties to jinglenodes_i18n.properties (No Upper Case N), and repacking the jar using the jar command ( jar -cf jinglenodes.jar -C jinglenodes ).

or the plugin file has been changed ?

can’t we directly change the plugin file for everyone ?

is there any way to write this in the plugin readme so that documentation is clear ?

Did someone find any solution on this?

1 Like