Jingle plugin bugs/problems

Updating Openfire to 3.7.1 I ran again into a problem I had the last time updating to 3.7.0 and this is the Jingle plugin. Personally I’d love to have Voice-Chat on my Openfire based Jabber server but I had to disable back then the Jingle plugin due to various problems. With the update the Jingle plugin had been automatically enabled again and I ran into the same problems. Maybe somebody can take a stab at this plugin and fix it up so in the future it doesn’t break openfire and make Voice-Char work.

So here is what breaks:

As soon as the Jingle plugin 0.0.3 is installed in the Openfire admin console zan entriy like admin.jn appears (no correct tab name, why?). Using this tab a bunch of options exist which are though all garbled in the form “??jn.something??” or alike. They do not seem to do anything but that’s another point.

The error logs are swamped with translation errors. As long as the Jingle plugin is installed on Openfire the error log fills up with a rate of over 1k/s. When I discovered this the last time the log file had been nearing 1GB in size (ouch) before I emergency pulled the plug and killed the process. That’s the most important problem to fix as it can seriously impact a system in the long run (sort of like a memory leak, just a log-leak).

The plugin itself doesn’t seem to work. In the admin console panel mentioned above a garbled warning about public IP is displayed (again with ?? all over the place). This is definitely wrong since my server has a public IP (which is found… at last the public IP shows between ?? bits) and I set the port forwarding as mentioned in the documentation. Nevertheless nothing seems to work.

It would be nice if (1) the plugin could be fixed to run correctly with Openfire especially since it is automatically enabled upon installing/updating Openfire (and thus I assume it’s a core plugin?). Furthermore it would help to ammend the documentation to contain information about why the plugin incorrectly moans about the public IP or in general information about how to setup the Jingle plugin correctly.

There is a ticket which describes the 1) (and probably is related to 2) also) - OF-444 It shows that it is still In Progress, but if i install Jingle Plugin Nodes on my 3.7.1 server, all menu names look ok and there is no log flooding, Can’t test whether it is working, cause i don’t know how to use this plugin, but it shows my verified publixc IP status is ok (checkmark icon). I think Thiago has made corrections to the svn, so the new version (with the same version number) was created when building new Openfire version. Can you try to reinstall this plugin and see if this fixes the issue?

Another strange thing is that it sounds that you have this plugin installed by default. But it shouldn’t. Openfire only installs Search plugin by default on a fresh install. Maybe you have tried Jingle Nodes Plugin before and it didn’t uninstall completely, so it goes back after you do Openfire upgrade. Btw, what OS are you on? Openfire has problems with deleting plugins on Windows, gets stuck and usually you have to stop Openfire and delete the remnants files manually (probably 5 years standing issue and even Jive (founders) couldn’t fix that). Works ok on Linux. So, stop Openfire and go to /openfire/plugins and delete jingle jar and folder.

I did already reinstall the plugin but got the same results as mentioned above. Is there a public svn-head build I could test?

I tested the plugin before on 3.7.0 with the same problems. I uninstalled the plugin using the admin console. Nevertheless the log-spamming continued and the jingle entry in the admin panel remained. I then went to the plugin directy and deleted the jingle jar and directory manually. This removed jingle then properly from Openfire and the admin panel entry and log spamming vanished. Upon upgrading to 3.7.1 jingle had been automatically installed. I could again not remove it properly using the admin panel and had to manually delete the files.

OS running: GenToo Linux 2.6.34-hardened-r6 SMP x86_64

I don’t know how to build this plugin from the svn, so i can’t give you a build to test. But i have installed this plugin from the Available plugins page and it worked fine. Btw, i’m using English locale and i see that it only has one translations file for this locale only. Maybe you are using some other locale?

So, you are installing Openfire from the “ports” systems (if i remember correctly about Gentoo)? Maybe the author of this package bundled this plugin together (and maybe others too) so you are getting it every time you install or upgrade. As i said, official installers only add Search plugin by default.

The set language is “English”. The LC_ALL on the system is though se to en_US.UTF-8 . Either way this could at best explain the log-flood but not why the plugin has a warning about the public IP although all is fine on the that end.

What goes for GenToo you mean “portage”? That’s the package manager they use. Quicke possible they bundle the plugin with the installer. It would make sense to do so in the case of Jingle… if it would not be broken :confused:

bug not delete this plugin is virus!!! =)


OpenFire 3.7.1 | FreeBSD / amd64