powered by Jive Software

Jitsi videobridge ofmeet - sip invite/registration

ok have elastix and openfire 3.9.3 and jitsi videobridge 1.3 installed on same machine

Can someone help with the sip registration element of the jitsi videobridge settings page?

Has anyone got the sip invite element working for jitsi videobridge plugin?

username = 211

password = 12345

Reg server = 192.168.20.1

Outbound = blank

Username
Password
Registration Server
Outbound Proxy

If I look on elastix, I can see it is not registering the 211 extension. 210 is the extension I want to invite.

I have also tried setting

org.jitsi.videobridge.sip.port.number = 5060

2014.08.22 09:25:00 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler handleIQ

2014.08.22 09:25:00 org.jitsi.videobridge.openfire.PluginImpl - uninviteNewParticipant sip:210@192.168.20.1

2014.08.22 09:25:12 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler handleIQ

2014.08.22 09:25:12 org.jitsi.videobridge.openfire.PluginImpl - inviteNewParticipant sip:st13pav6c6yctyb9@conference.192.168.20.1 sip:210@192.168.20.1

2014.08.22 09:25:12 org.ifsoft.sip.CallSession - CallSession creation pbx1.fingleton.local

2014.08.22 09:27:36 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler handleIQ

2014.08.22 09:27:36 org.jitsi.videobridge.openfire.PluginImpl - uninviteNewParticipant sip:210@192.168.20.1

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantLeft st13pav6c6yctyb9@conference.192.168.20.1 a9c49666@192.168.20.1/a9c49666

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - FocusAgent - closeColibri

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - expireColibriChannel a9c49666@192.168.20.1/a9c49666 f(mi6ru) null 65733d8a8c28acba 32eaa546a6a9a4e3

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - routeColibriEvent - P a9c49666@192.168.20.1/a9c49666 f(mi6ru)

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - bridgeJoin event to room occupants of st13pav6c6yctyb9

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - removeColibriChannel 0

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler roomDestroyed st13pav6c6yctyb9@conference.192.168.20.1

2014.08.22 09:27:37 org.jitsi.videobridge.openfire.PluginImpl - FocusAgent - closeColibri

Look at the log files for sip. You might need to specify the outbound proxy as well

Thanks but where are the log files for sip stored, can’t find them currently?

Also specified 192.168.20.1 as my outbound proxy, same result unfortunately,

2014.08.29 13:32:44 org.jitsi.videobridge.openfire.PluginImpl - processUserAnswer c4429155@192.168.20.1/c4429155 f(74nvw)

2014.08.29 13:32:44 org.jitsi.videobridge.openfire.PluginImpl - bridgeJoin event to room occupants of qtn274mgpq4cxr

2014.08.29 13:32:44 org.jitsi.videobridge.openfire.PluginImpl - bridgeJoin event to room occupant c4429155@192.168.20.1/c4429155

2014.08.29 13:32:45 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler handleIQ

<colibri xmlns=“urn:xmpp:rayo:colibri:1” action=“invite” muc=“qtn274mgpq4cxr@conference.192.168.20.1” from=“sip:qtn274mgpq4cxr@conference.192.168.20.1” to="$

2014.08.29 13:32:47 org.jitsi.videobridge.openfire.PluginImpl - inviteNewParticipant sip:qtn274mgpq4cxr@conference.192.168.20.1 sip:210@192.168.20.1

2014.08.29 13:32:47 org.ifsoft.sip.CallSession - CallSession creation pbx1.fingleton.local

2014.08.29 13:32:51 org.jitsi.videobridge.openfire.PluginImpl - FocusAgent deliver

<iq type=“error” id=“answer-f(74nvw)-1409315564225” from=“jitsi-videobridge.192.168.20.1” to="jitsi.videobridge.qtn274mgpq4cxr@192.168.20.1/jitsi.videobridge.$

2014.08.29 13:32:51 org.jitsi.videobridge.openfire.PluginImpl - FocusAgent - closeColibri

2014.08.29 13:32:51 org.jitsi.videobridge.openfire.PluginImpl - sendRayoEvent - c4429155@192.168.20.1/c4429155 f(74nvw)

2014.08.29 13:33:08 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler handleIQ

2014.08.29 13:33:08 org.jitsi.videobridge.openfire.PluginImpl - uninviteNewParticipant sip:210@192.168.20.1

"jitsi.videobridge.qtn274mgpq4cxr@192.168.20.1/jitsi.videobridge

I don’t think IP address will work. You need a proper domain name

ok so I think I getting closer.

Re-installed on a machine with a proper domain name.

Capture.PNG

The logs now show the following:

2014.09.20 15:14:46 org.jivesoftware.openfire.container.AdminConsolePlugin - Admin console listening at:

http://xyz.ie:9090

https://xyz.ie:9091

2014.09.20 15:14:46 org.jivesoftware.util.Log - Initializing phone plugin

2014.09.20 15:14:46 org.jivesoftware.util.Log - Initializing Asterisk Manager connection

2014.09.20 15:14:46 org.asteriskjava.manager.internal.ManagerConnectionImpl - Connecting to 192.168.20.1:5038

2014.09.20 15:14:46 org.jitsi.videobridge.openfire.PluginImpl - Initialize Web App jitsi

2014.09.20 15:14:47 org.ifsoft.nodejs.openfire.PluginImpl - checkNatives node executable path /usr/share/openfire/plugins/nodejs/native/linux-64/node

2014.09.20 15:14:47 org.ifsoft.nodejs.openfire.PluginImpl - executeScript executable path node_modules/ep_etherpad-lite/node/server.js /usr/share/openfire/plugins/jitsivideobridge/apps/ofmeet

2014.09.20 15:14:47 org.asteriskjava.manager.internal.ManagerConnectionImpl - Connected via Asterisk Call Manager/1.3

2014.09.20 15:14:47 org.ifsoft.nodejs.openfire.NodeThread - In stopThread()

2014.09.20 15:14:47 org.ifsoft.nodejs.openfire.NodeThread - Started Node

2014.09.20 15:14:47 org.ifsoft.nodejs.openfire.NodeThread - Started Node Console Reader

2014.09.20 15:14:47 org.ifsoft.nodejs.openfire.NodeThread - Start run()

2014.09.20 15:14:47 org.asteriskjava.manager.internal.ManagerConnectionImpl - Successfully logged in

2014.09.20 15:14:47 org.asteriskjava.manager.internal.EventBuilderImpl - No event class registered for event type ‘fullybooted’, attributes: {status=Fully Booted, event=FullyBooted, privilege=system$

2014.09.20 15:14:47 org.hibernate.validator.internal.util.Version - HV000001: Hibernate Validator 5.0.1.Final

2014.09.20 15:14:47 org.jivesoftware.openfire.spi.ConnectionManagerImpl - Started server (unencrypted) socket on port: 5269

2014.09.20 15:14:47 org.jivesoftware.openfire.spi.ConnectionManagerImpl - Started plain (unencrypted) socket on port: 5222

2014.09.20 15:14:47 org.jivesoftware.openfire.spi.ConnectionManagerImpl - Started SSL (encrypted) socket on port: 5223

2014.09.20 15:14:49 org.asteriskjava.manager.internal.ManagerConnectionImpl - Determined Asterisk version: Asterisk 1.0

2014.09.20 15:14:49 org.asteriskjava.live.internal.QueueManager - Adding new queue AsteriskQueue[name=‘default’,max=‘0’,serviceLevel=‘0’,weight=‘0’,entries=’[]’,s ystemHashcode=841120773]

2014.09.20 15:14:49 org.asteriskjava.live.internal.AsteriskServerImpl - Initializing done

2014.09.20 15:14:49 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Locked Out Accounts

2014.09.20 15:14:50 JitsiVideobridgeStack - the sip stack timer gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started

2014.09.20 15:14:50 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Group

2014.09.20 15:14:50 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Group Metadata Cache

2014.09.20 15:14:50 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Remote Server Configurations

2014.09.20 15:14:50 org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Secret Keys Cache

2014.09.20 15:14:50 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantJoined fwchat@conference.xyz.ie test@xyz.ie/jitsi-23uujnv Test

2014.09.20 15:14:50 org.ifsoft.sip.SipService - VoiceBridge adding SIP registration: 211 with user 211 host 192.168.20.1

2014.09.20 15:14:50 org.ifsoft.sip.RegisterProcessing - Start registering…192.168.20.1

2014.09.20 15:14:50 org.ifsoft.sip.RegisterProcessing - Registering with 192.168.20.1

2014.09.20 15:14:51 org.ifsoft.sip.RegisterProcessing - Could not send out the register request! Invalid argument

2014.09.20 15:14:51 org.jitsi.videobridge.openfire.PluginImpl - Initialize SIP Stack at meeting:5060

2014.09.20 15:14:51 org.jitsi.videobridge.openfire.PluginImpl - Native lib folder already exist.

2014.09.20 15:14:51 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantJoined fwchat@conference.xyz.ie fergalomahony@xyz.ie/jitsi-2uikndd 2101

Note the lines:

2014.09.20 15:14:50 org.ifsoft.sip.SipService - VoiceBridge adding SIP registration: 211 with user 211 host 192.168.20.1

2014.09.20 15:14:50 org.ifsoft.sip.RegisterProcessing - Start registering…192.168.20.1

2014.09.20 15:14:50 org.ifsoft.sip.RegisterProcessing - Registering with 192.168.20.1

2014.09.20 15:14:51 org.ifsoft.sip.RegisterProcessing - Could not send out the register request! Invalid argument

I found this post and set the server properties as per this post

https://igniterealtime.jiveon.com/thread/52617

but as you can see it will not register and the log message “org.ifsoft.sip.RegisterProcessing - Could not send out the register request! Invalid argument” is not helpful

Any ideas??

If I initiate an ofmeet and invite a sip phone 2101@192.168.20.1, here is the log output:

2014.09.20 15:30:44 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler handleIQ

2014.09.20 15:30:44 org.jitsi.videobridge.openfire.PluginImpl - inviteNewParticipant sip:eq3gj6cnt1grdx6r@conference.xyz.ie sip:2101@192.168.20.1

2014.09.20 15:30:44 org.ifsoft.sip.CallSession - CallSession creation meeting

2014.09.20 15:30:45 org.ifsoft.sip.CallSession - buildSDP v=0

o=JabberGW 3620212245 3620212245 IN IP4 127.0.0.1

s=Jabber Call

c=IN IP4 127.0.0.1

t=0 0

m=audio 50000 RTP/AVP 0 101

a=a:sendrecv

a=a:rtcp-mux

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

However the phone never rings. Seems like getting closer and the problem I see is that the sip user settings in jitsivideobridge are not quite right.

Hello to allo.

I am having also some problems with Jitsi and SIP registration.

Although I’ve set server, extension and password, from my asterisk logs, the Jitsi tries to connect as “admin@IPofserver”

Is there anywhere else I can force the setting to change?

I am using latest Openfire, Jitsivideobridge and asterisk 11.

Thanks

Evangelos,

See JitsiVideobridge SIP Registration post and set the system properties manually as per this post.

This changes Jitsivideobridge from trying to register admin@IPofserver to extension-to-be-registered@@IPofserver

However as you can see from my post above, this also fails.

Can I ask how you log the registration attempt in your asterisk server - sorry don’t know asterisk in much detail?

you need to see the logs of sip_debug.log and sip_server.log. mine looks like this

sip_server.log

<!-- Use the  Trace Viewer in src/tools/tracesviewer to view this  trace  Here are the stack configuration properties javax.sip.IP_ADDRESS= btg199251
javax.sip.STACK_NAME= JitsiVideobridgeStack
javax.sip.ROUTER_PATH= null
javax.sip.OUTBOUND_PROXY= null
-->
<description logDescription="JitsiVideobridgeStack" name="JitsiVideobridgeStack" auxInfo="null"/>

sip_debug.log

WARN - using default tls security policy
INFO - the sip stack timer gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started

Mine are exactly the same.

not sure what this tells us??

sip_server.log

<description

logDescription=“JitsiVideobridgeStack”

name=“JitsiVideobridgeStack”

auxInfo=“null”/>

sip_debug.log

WARN - using default tls security policy

INFO - the sip stack timer gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started

If you have this working, could you post the following settings from your working Openfire

Hi,

here are the latest lines from the sip_server.log

The 192.168.2.100 is the local IP of the server(I’ve tried also with the localhost, same result).

As mentioned, the Openfire runs on the same system as the Asterisk server(FreePBX version).

<message

from=“192.168.2.100:5060”

to=“127.0.0.1:5070”

time=“1411290683762”

isSender=“false”

transactionId=“z9hg4bk-373532-8eb6a29e7fd73b49172e960065d6675d”

callId="7893e1be7ef7fb3573b9ba680d0f0218@127.0.0.1"

firstLine=“SIP/2.0 403 Forbidden”

<![CDATA[SIP/2.0 403 Forbidden^M Via: SIP/2.0/UDP 127.0.0.1:5070;branch=z9hG4bK-373532-8eb6a29e7fd73b49172e960065d6675d;received= 127.0.0.1;rport=5070^M From: "admin" ;tag=3640615^M To: "admin" ;tag=as54c33848^M Call-ID: 7893e1be7ef7fb3573b9ba680d0f0218@127.0.0.1^M CSeq: 2 REGISTER^M Server: FPBX-12.0.1rc20(12.5.0)^M Allow: INVITE,ACK,CANCEL,OPTIONS,BYE,REFER,SUBSCRIBE,NOTIFY,INFO,PUBLISH,MESSAGE^M Supported: replaces,timer^M Content-Length: 0^M ^M ]]>

I have read the "JitsiVideobridge SIP Registration " post, I do not have a SipService.java properties file. I have downloaded jitsi direct from the plugins list.

My JitsiVideo bridge settings look like this:

I’ve also tried without the proxy, with localhost, with 127.0.0.1, no change.

I’ve also reviewed the properties in server properties page.

The sip_debug.log file gives me these:

INFO - <message

from=“192.168.2.100:5060”

to=“127.0.0.1:5070”

time=“1411290683762”

isSender=“false”

transactionId=“z9hg4bk-373532-8eb6a29e7fd73b49172e960065d6675d”

callId="7893e1be7ef7fb3573b9ba680d0f0218@127.0.0.1"

firstLine=“SIP/2.0 403 Forbidden”

<![CDATA[SIP/2.0 403 Forbidden^M Via: SIP/2.0/UDP 127.0.0.1:5070;branch=z9hG4bK-373532-8eb6a29e7fd73b49172e960065d6675d;received= 127.0.0.1;rport=5070^M From: "admin" ;tag=3640615^M To: "admin" ;tag=as54c33848^M Call-ID: 7893e1be7ef7fb3573b9ba680d0f0218@127.0.0.1^M CSeq: 2 REGISTER^M Server: FPBX-12.0.1rc20(12.5.0)^M Allow: INVITE,ACK,CANCEL,OPTIONS,BYE,REFER,SUBSCRIBE,NOTIFY,INFO,PUBLISH,MESSAGE^M Supported: replaces,timer^M Content-Length: 0^M ^M The Asterisk log shows me that the Jitsi tries to register with the user "admin" which is something I really cannot understand. NOTICE[30907]: chan_sip.c:27990 handle_request_register: Registration from '"admin" ' failed for '127.0.0.1:5070' - Wrong password Any ideas?

Does anyone have a working SIP registration within Ofmeet plugin?

I am under the impression that nobody has this working from reading the forum / lack of answers / examples of working settings

Thanks

Dele,

can you please help us setup the Openfire with Jitsivideobridge and with SIP registration working?

I am trying this the last two weeks now with no positive results.

Can you provide us with a how-to or a step by step solution on how to get this work correct?

Thank you

Anyone???

Did you make any progress on this Fergalom?

I really do not get it, such a nice plugin and no support,no documentation or what so ever.

Anybody that can help on this?

Sorry for late reply. There is abug somewhere inthe registration details. The best advice is to look at the source code and find the correct property names. Also, i have never tested with a pbx. Only used voipcheap.com, voxbone inum and direct sip addresses