powered by Jive Software

Jitsi Videobridge on Centos 7

Hi

Im trying to get Jitsi VideoBridge Plugin to install. I have a centos server running 4.3.2. I can add the plugin into the plugin section and Jitsi Videobridge Openfire Plugin shows as installed however its showing version 0.0.0 in the version column.

Also I don’t have a Jitsi Videobridge section in the server tab.

I have tried rebooting. I have also tried the last 3 version available in the download.

Can anyone suggest anything else I can try?

Tim

A quick look at your openfire log files might give a clue :wink:

Can you make anything of this:

367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
at org.xmpp.component.AbstractComponent.start(AbstractComponent.java:967) [tinder-1.3.0.jar:?]
at org.jivesoftware.openfire.component.InternalComponentManager.addComponent(InternalComponentManager.java:155) [xmppserver-4.3.2.jar:4.3.2]
at org.jitsi.videobridge.openfire.PluginImpl.initializePlugin(PluginImpl.java:338) [jitsi-videobridge-openfire-2.7-SNAPSHOT.jar!/:?]
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:597) [xmppserver-4.3.2.jar:4.3.2]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:354) [xmppserver-4.3.2.jar:4.3.2]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:342) [xmppserver-4.3.2.jar:4.3.2]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_202]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_202]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_202]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_202]
2019.07.03 17:30:05 ERROR [org.jitsi.impl.osgi.framework.AsyncExecutor]: org.jitsi.impl.osgi.framework.BundleImpl - Error starting bundle: org.jitsi.videobridge.octo.OctoRelayService@180ff659
java.lang.NullPointerException: null
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getProperty(ConfigurationServiceImpl.java:389) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getString(ConfigurationServiceImpl.java:1218) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getString(ConfigurationServiceImpl.java:1235) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.videobridge.octo.OctoRelayService.start(OctoRelayService.java:90) ~[jitsi-videobridge-1.1-20190208.160347-106.jar!/:?]
at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:307) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:472) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:137) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:122) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:28) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:231) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
2019.07.03 17:30:05 ERROR [org.jitsi.impl.osgi.framework.AsyncExecutor]: org.jitsi.impl.osgi.framework.launch.FrameworkImpl - Error changing start level
org.osgi.framework.BundleException: BundleActivator.start
at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:327) ~[jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:472) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:137) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:122) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:28) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:231) [jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
Caused by: java.lang.NullPointerException
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getProperty(ConfigurationServiceImpl.java:389) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getString(ConfigurationServiceImpl.java:1218) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getString(ConfigurationServiceImpl.java:1235) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.videobridge.octo.OctoRelayService.start(OctoRelayService.java:90) ~[jitsi-videobridge-1.1-20190208.160347-106.jar!/:?]
at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:307) ~[jitsi-android-osgi-1.0-20180322.162617-2.jar!/:?]
… 5 more
2019.07.03 17:30:05 ERROR [pool-989-thread-1]: org.jivesoftware.openfire.container.PluginManager - An exception occurred while loading plugin ‘jitsivideobridge-32’:
java.lang.NullPointerException: null
at org.jitsi.impl.configuration.ConfigurationServiceImpl.getProperty(ConfigurationServiceImpl.java:389) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.impl.configuration.ConfigurationServiceImpl.setProperty(ConfigurationServiceImpl.java:186) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.impl.configuration.ConfigurationServiceImpl.setProperty(ConfigurationServiceImpl.java:174) ~[libjitsi-1.0-20190130.211714-376.jar!/:?]
at org.jitsi.videobridge.openfire.PluginImpl.initializePlugin(PluginImpl.java:348) ~[jitsi-videobridge-openfire-2.7-SNAPSHOT.jar!/:?]
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:597) [xmppserver-4.3.2.jar:4.3.2]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:354) [xmppserver-4.3.2.jar:4.3.2]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:342) [xmppserver-4.3.2.jar:4.3.2]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_202]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_202]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_202]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_202]

Hmmm. I disabled selinux and rebooted, now I have a plugin.title tab under servers with raw jar menus (example below), Im not sure if its the selinux disabled or the reboot however I have rebooted many times before thinking that was the resolution and it didn’t sort it. Plug still says version 0

Menu example:

???config.page.description???
???config.page.configuration.interfaces.title???
???config.page.configuration.interfaces.info???
???config.page.configuration.interfaces.allow-all???
???config.page.configuration.interfaces.allow-specific???
???config.page.configuration.interfaces.allow??? eth0 (00:15:5d:01:65:1b)

Tim

The menus look like that because you are using non English (or are you seeing your nickname?) UI in Admin Console and plugin is missing this language. Or maybe your plugin’s jar has upper case letters in its name and this causes problems on Linux. Stop Openfire, make plugin’s jar file all lower case, delete its folder in plugins folder and run Openfire.

Thanks for coming back to me. The Language is set to EN and the jitsivideobridge-32.jar is all lowercase.

When I remove the plugin I have made sure that the folder and .jar files have gone before retrying.

Tim

You can also try renaming to just jitsivideobridge.jar, but it seems that this won’t make difference. Maybe Dele will have some ideas.

Ive got it working. Unfortunately I did two things at once so I don’t know what solved it.

  1. I renamed the plugin to just jitsivideobridge.jar
  2. But I also upgrade openfire to 4.4.0 (From 4.3.2)

It still shows 0.0.0 version in the plugins page but we’re all good. Well from what I can see.

Cheers

Tim

1 Like