powered by Jive Software

Jive Messenger 2.3.0 Beta 2 Released

Jive Messenger 2.3.0 beta 2 has been url=http://www.jivesoftware.org/downloads.jspreleased[/url]. This version includes some improvements such as simplified setup process, new features such as vCard and LDAP integration and many bug fixes. Read the url=http://www.jivesoftware.org/builds/messenger/docs/2.3.0.beta2/changelog.htmlchange log[/url] to learn the complete list of changes.

Since JM 2.3.0 beta 1 plugins need to be updated to latest version. Moreover, the presence plugin has changed its icons to overcome a license limitation. You can get the new plugins url=http://www.jivesoftware.org/messenger/plugins-beta.jsphere[/url].

Source code of the new beta can be found here:

http://www.jivesoftware.org/builds/messenger/jive_messenger_src_2_3_0_beta_2.tar .gz

http://www.jivesoftware.org/builds/messenger/jive_messenger_src_2_3_0_beta_2.zip

Enjoy!

Jive Team

Hi

I have version 2.2.2 how can I make upgrade. I tried once and server wasn’'t working maybe I did something wrong so please give me some leads.

Best regard

Samson

The Windows installer will pretty much “do the right thing” in terms of upgrading your existing install. You won’'t lose your existing data, and it will prompt you on if it should overwrite your install settings (most people will want to choose no).

Regards,

– Gato

But I have linux

Please any anyone tell me how to do an upgrade.

I would do (and i will when 2.3.0 final be out), download tar.gz package, extract it, stop JM server and overwrite everything except embedded-db, conf and logs. Start it again.

Language and Time tab doesnt save settings. Time Zone.

The SSL certificate received from the server has errors.

Certificate does not match host: /C=US/ST=OR/L=Portland/O=Jive Software/OU=XMPP/CN=John Doe

Certificate fingerprint:

I’'m getting this error with Exodus since first 2.3.0 beta as i remember. I have disabled SSL connections, but it seems Exodus is still trying to get a cert. If i try to uninstall certs in Admin Console when i cant login to server anymore.

With 2.2.2 i have never seen such warning. SSL disbled too (cant remeber if i have uninstalled certs on 2.2.2 too, will check this on Monday).

Language and Time tab doesnt save settings. Time Zone.

Filed as JM-462 and now fixed.

-Matt

Wroot,

The issue is that 2.3.0 now supports SASL and TLS so Exodus is attempting an encrypted connection. It’'s definitely now more important to create your own valid security certificate.

-Matt

It’'s definitely now more important to create your own

valid security certificate.

And why couldnt i just disable it? If only this is not an Exodus only issue. I see that Exodus is always trying to establish encrypted connection whenever it’'s possible. Cant disable it in Exodus options. But with 2.2.2 i have disabled 5223 port and Exodus was calm about that. So why cant i do the same with 2.3.0? I have seen a lot of problems with certs in forum, i see this is a complex thing. But we dont need this yet and i have plenty of other work to do. Of course, i can select “Always accept this cert” when this warning comes up, but this will be too distracting for our users, so my IT boss will not let me upgrade JM.

Hey wroot,

For the final release (out this week) we are going to include JM-393. So from the server you will be able to indicate if TLS is disabled (your case), optional or required.

FYI, clients connecting to port 5223 are using the old SSL method so a certificate is required. Since JM 2.3.0 TLS is also supported. Therefore, clients connecting to port 5222 will initially have a plain (unencrypted) connection to the server. When TLS is available clients will try to secure (i.e. encrypt) the socket thus a certificate is required again. In JM 2.3.0 beta2 there is no way to disable TLS so a certificate will be used if the client, Exodus in your case, supports TLS.

Regards,

– Gato

Have seen this request but didnt thought it could become my case too OK, have voted too, waiting for 2.3.0 Final to test, thanx. And sorry for a little rushing on you guys, not a most pleasent morning today, heh…

Is anybody else getting a:

tar: A lone zero block at 52869

when untarring the source? Is that normal?

this is one of my first threads:

http://www.jivesoftware.org/community/thread.jspa?messageID=95616&#95616

yes, this is normal, i’'m seeing it all the time i upgrade my JM installation.

I installed 2.3.0 beta 2, and experienced as following when I clicked menu:

  • Server > Content Filter (–> Content Filter plugin), or

  • Server > Presence Service (–> Presence Service plugin), or

  • Users/Groups > User Import & Export (–> User Import Export plugin)

admin console can’'t displayed left navigation menu (displayed previously before I clicked one of above menus).

Are these bugs?

Thx.

comm, that’'s because Admin Console backend was changed a bit, so old plugins are not showing right. There are plugins made for beta version or something like that. But i cant find the link.

But i cant find the link.

Here it is:

http://www.jivesoftware.org/messenger/plugins-beta.jsp

That reminds me – I’'ve noticed that the new plugin configure pages in the Admin Console have a broken link for the help question mark that is normally in the upper right hand corner of the page.

Time Zone issue fixed. But there is no confirmation message after saving the setings