powered by Jive Software

Jive messenger in openbsd

dlg@scotty:~$ cd /usr/local/jive_messenger/

dlg@scotty:/usr/local/jive_messenger$ java -version

Java HotSpot™ Client VM warning: Can’'t detect initial thread stack location - find_vma failed

java version “1.5.0_04”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)

Java HotSpot™ Client VM (build 1.5.0_04-b05, mixed mode, sharing)

dlg@scotty:/usr/local/jive_messenger$ bin/messenger

No suitable Java Virtual Machine could be found on your system.

The version of the JVM must be at least 1.5.

Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

You can also try to delete the JVM cache file /home/dlg/.install4j

dlg@scotty:/usr/local/jive_messenger$ uname -ap

NetBSD scotty.dorkzilla.org 2.0 NetBSD 2.0 (GENERIC) #0: Wed Dec 1 10:58:25 UTC 2004 builds@build:/big/builds/ab/netbsd-2-0-RELEASE/i386/200411300000Z-obj/big/build s/ab/netbsd-2-0-RELEASE/src/sys/arch/i386/compile/GENERIC i386 i386

dlg@scotty:/usr/local/jive_messenger$ pkg_info|grep sun

sun-jre15-5.0.4nb1 Sun’'s Java™ 2 Runtime Environment 1.5.0

sun-jdk15-5.0.4nb1 Sun’'s Java™ 2 SDK, Standard Edition 1.5.0

dlg@scotty:/usr/local/jive_messenger$

the basic gist of it is, i have java 1.5 installed, my path knows about it, yet messenger is unhappy. this is a netbsd/2.0 computer, so java is run in linux compatibility mode … i guess i’'m not sure what information you actually need from me, so … yeah… ideas?

dlg,

I’'m not really sure that Java 1.5 will work on BSD – that looks like an internal error. Can you try running other Java programs? Perhaps some of the samples that ship with the JDK?

Regards,

Matt

i was getting the same error while running JM autostart daemon in Archlinux. I have fixed it by putting one line to a daemon file:

export JAVA_HOME=/opt/java/jre

though Java is installed correctly and JM is starting normally when launching manually.