powered by Jive Software

Jive Newbie bewildered and lost

I’‘m currently doing my first install of JM and I have the box installed, but it’‘s just not working. I can’‘t login to it and in the Java admin console, I cannot access the SSL page. I’‘m running Debian (unstable) 2.6.8 kernel, JRE 1.5.0_04, JM 2.2.2 and Gaim 1.5.0. I’‘m trying to make it use SSL/TLS encryption and authenticate against my AD LDAP. The install seems very straight forward and I followed all instructions closely. Below is the only error message I’‘m getting from logs. I enabled debug but I’‘m getting nothing from it. Gaim simply tells me “Connection Failed.” Below the log output you will find a copy of my jive-messenger.xml. I’‘ve been kicking around Linux boxes for about 5 years, but I’‘m still not very experienced with them. We are still primarily a Windows shop. Any help would be appreciated, I’‘ve spent the better part of two days looking through your forum and I’'m still unable to fix my issues. Sorry about the long post, just wanted to put as much info out there as possible hoping to get some help.

Thanks in advance,

Mark


LogOutput----


at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.messenger.starter.ServerStarter.start(ServerStarter.java:82)

at org.jivesoftware.messenger.starter.ServerStarter.main(ServerStarter.java:46)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.install4j.runtime.Launcher.main(Unknown Source)

2005.09.28 14:40:24 org.jivesoftware.messenger.container.AdminConsolePlugin.initializePlugin(AdminCo nsolePlugin.java:184) Trouble initializing admin console


/LogOuput----



jive-messenger.xml----



/jive-messenger.xml----


Hi Mark,

Looks like the LDAP settings section of your jive-messenger.xml is commented out, that would explain why you’‘re having trouble connecting to your AD. Try removing the “<!” and “>” comment markers before and after the tags respectively. It also looks like you might have some stray “-” characters floating around, but that maybe just the the way the forums are formatting your data. When you’'re done your file should look like the one below.

Hope that helps,

Ryan

/pre

Thanks a ton for the help. Always is something simple, but I still cannot connect and now when I try to log into the admin console, I’'ve been put into a loop on the setup. It makes me run the setup, I run it, restart the JM server, then when I try to login again, it tries to make me run the process again. No clue.

Hi Mark,

That’‘s strange about the loop you’‘re finding yourself in. After you’'ve gone through the setup process and have shut Messenger down, look in your jive-messenger.xml file and make sure the setup flag is set to true, i.e. section.

Let me know how it goes.

Thanks,

Ryan

Ryan,

Thanks for the advice. I followed your instructions and same deal. I’‘m think I’'m going to try and build from scratch again and see what happens. Thanks again.

Mark

Ok, so I rebuilt from scratch, and now everything seems to semi-working. I can see the server running, I’‘m not in the setup loop any longer, and I can view my SSL page from the admin console, complete with keys. I can actually even login and see that other users are logged in, but I cannot communicate between users nor can I send authorization requests. In the admin console I can see that they are logged in and are using encrypted transmission. I get the same results if I login unencrypted. I’‘m using Gaim 1.5 and using the “Force Old SSL” option with port 5223. If I try to use TLS, it gives me “XML Parse Error”. So I’‘ve gotten this far, I think I’'m getting close to making this happen. Any more help that can be offered will be greatly appreciated. Thank you all again.

Mark

I thought my question my be answered at this thread:

http://www.jivesoftware.org/community/thread.jspa?threadID=16013&tstart=0

But it turns out it’‘s a different problem. Even using the full user name user@server.company.com it still doesn’‘t work, I can see when they log in and out, but it won’'t let me send communication or authorization requests.

Hi Mark,

Could you try using a client other than Gaim, such as Psi or Exodus, to see if you still have the same problem?

Thanks,

Ryan

Per your advice, I tried PSI, and it gave me this error:

There was an error communicating with the Jabber server. Details: Authentication error: No Appropriate mechanism available for given security settings.

So then I downloaded Exodus for my windows box, ran Gaim on my linux box, and at that point I was able to communicate. Awesome!

Either way, it’‘s working now, I would like to know why Gaim on both ends won’'t work. Any ideas? Something else that is weird, is that it takes forever for the first message to show up, over a minute. But once the first message is sent through, the rest are instant. I would like to keep this open and maybe get some back and forth on these. I saw a similar thread here:

http://jivesoftware.org/community/thread.jspa?threadID=15156

But I’‘m not having the exact same symptoms, plus I’'m sure we are using the right user@hostname format because I preset them all up in a group. Also, does anyone know if there are any plans to build a Linux port of Exodus?

Okay, I’'m an IDIOT! The slowdown is being caused by the fact that I was logging in to my Jabber client, gaim, exodus, psi whatever as username@chatter.sses.net, obviously chatter.sses.net being my jabber server, while it was listing all users as just username@chatter.

This post:

http://jivesoftware.org/community/thread.jspa?threadID=15156

was correct. Thank all of you, especially RyanG for all of your help. This forum and development group is a true credit to the Open Source Community.

Sincerely,

Mark

Message was edited by:

KabarsEdge

Great forum and great people. Keep up the good work, both at Jive and in the Open Source Community.

Mark

Hi Mark,

Good to hear everything is working now.

As for your question about a port of Exodus to Linux, you’‘ll probably get a better response if you posted it directly to their mailing list. If you’'re looking for different clients for Linux you might want to start url=http://www.jabber.org/software/clients.shtmlhere[/url].

Cheers,

Ryan