powered by Jive Software

Jive server disconnects clients

I am running the newest version of jive Messenger on a win 2003 server. I have tried multiple clients to connect including Exodus and wannachat. The clients will connect but the keep getting disconnected every couple minutes or so. The Error log from the jive server is as follows:

org.jivesoftware.messenger.PacketException: Could not send packet - no route

at org.jivesoftware.messenger.spi.PacketDelivererImpl.deliver(PacketDelivererImpl. java:49)

at org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:50)

at org.jivesoftware.messenger.IQRouter.handle(IQRouter.java:202)

at org.jivesoftware.messenger.IQRouter.route(IQRouter.java:73)

at org.jivesoftware.messenger.PacketRouter.route(PacketRouter.java:65)

at org.jivesoftware.messenger.net.SocketReadThread.readStream(SocketReadThread.jav a:285)

at org.jivesoftware.messenger.net.SocketReadThread.run(SocketReadThread.java:105)

2005.04.27 08:24:19 [org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:71)

] Internal server error

org.jivesoftware.messenger.PacketException: Could not send packet - no route

at org.jivesoftware.messenger.spi.PacketDelivererImpl.deliver(PacketDelivererImpl. java:49)

at org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:50)

at org.jivesoftware.messenger.IQRouter.handle(IQRouter.java:202)

at org.jivesoftware.messenger.IQRouter.route(IQRouter.java:73)

at org.jivesoftware.messenger.PacketRouter.route(PacketRouter.java:65)

at org.jivesoftware.messenger.net.SocketReadThread.readStream(SocketReadThread.jav a:285)

at org.jivesoftware.messenger.net.SocketReadThread.run(SocketReadThread.java:105)

2005.04.27 08:24:19 [org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:71)

] Internal server error

org.jivesoftware.messenger.PacketException: Could not send packet - no route

at org.jivesoftware.messenger.spi.PacketDelivererImpl.deliver(PacketDelivererImpl. java:49)

at org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:50)

at org.jivesoftware.messenger.IQRouter.handle(IQRouter.java:202)

at org.jivesoftware.messenger.IQRouter.route(IQRouter.java:73)

at org.jivesoftware.messenger.PacketRouter.route(PacketRouter.java:65)

at org.jivesoftware.messenger.net.SocketReadThread.readStream(SocketReadThread.jav a:285)

at org.jivesoftware.messenger.net.SocketReadThread.run(SocketReadThread.java:105)

Any ideas what might be going on here???

Hey rich,

Is your server shutting down? The error that you are experiencing in line 49 occurs only when the server is shutting down and at the same time a packet was being sent. Let me know if that is your case.

Thanks,

– Gato

Gato,

I am not shutting the server down. It is always running. I have my clients set to automatically reconnect after 20 seconds. When they reconnect they may stay live for a minute or two, then it happens again.

I have been researching this all day and can not get a grip on it…