powered by Jive Software

Jive under Windows 2003

Hi,

I was able to install Jive under windows fine, but the problem I have is when i try and configure it. I am using SQL 2005. And it can never find the path to the database class on the web config.

Has anyone been able to get this working? I tried installing both the old JDBC drivers and the new 2005 ones, but nothing seemed to work…

Also since this is my first time with any jabber software, if anyone has any hints for making it work well under windows I would love the info!

Thank you

Bruce

Bruce,

What’‘s the specific error message you’'re getting?

Regards,

Matt

Bruce,

What’‘s the specific error message you’'re getting?

Regards,

Matt

Under JDBC driver on the web config I get:

Unable to load the specified JDBC driver. Please verify the name of the driver is correct and that the driver is in the classpath of this server (usually the ‘‘lib’’ directory). If you add a driver to your classpath you will neeed to restart the server.

Message was edited by:

BruceM

Did you download and install the JAR file into the lib directory of your Jive Messenger installation?

The download is at: http://www.microsoft.com/downloads/details.aspx?FamilyID=07287b11-0502-461a-b138 -2aa54bfdc03a&DisplayLang=en

Regards,

Matt

Yes I did, and this may be a probelm as I am using sql 2005.

There is a JDBC file for 2005 but it is named differently so perhaps jive cant find that?

Try the following:

Put “sqljdbc.jar” in the lib directory of Jive Messenger and restart. When you get to the database page, use the following values:

JDBC Driver Class: com.microsoft.sqlserver.jdbc.SQLServerDriver

Database URL: jdbc:sqlserver://localhost/database=[foo]

Note that both the JDBC driver name and URL format have changed for the SQL Server 2005 JDBC driver. Please let me know how that works.

Regards,

Matt

Ok I did that now on the web form I get the following message:

The Jive Messenger database schema does not appear to be installed.

I ran the script called

\Jive Messenger\resources\database\messenger_sqlserver.sql

prior to installing.

Select * from jiveVersion returns major 2 minor 2 but…

Also on the console, I get this long error string:

Found old database schema (2.0). Upgrading to latest schema.

Database upgrade failed. Please manually upgrade your database.

com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name ‘‘jiveID’’.

at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(Unknown Source)

at com.microsoft.sqlserver.jdbc.IOBuffer.processPackets(Unknown Source)

at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(Unknown Source)

at com.microsoft.sqlserver.jdbc.SQLServerStatement.sendExecute(Unknown Source)

at com.microsoft.sqlserver.jdbc.SQLServerStatement.doExecuteQuery(Unknown Source)

at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeQuery(Unknown Source)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp.testConn ection(setup_002ddatasource_002dstandard_jsp.java:77)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp._jspServ ice(setup_002ddatasource_002dstandard_jsp.java:270)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

Message was edited by:

BruceM

(Tried again, same error but more readable this time so replaced it)

Message was edited by:

BruceM

YAY

I had forgotten to put the port after localhost on the connect string. Now its working fine!

I have one probelm still though, that I think is a problem at least. When I start up Messenger console, I get 2 red errors first, then everything seems to be ok.

Error starting server listener on port 5269: Address already in use JVM_Bind

Error starting XMPP listerer on port 5222: Address already in use JVM_Bind

Error starting server listener on port 5269: Address

already in use JVM_Bind

Error starting XMPP listerer on port 5222: Address

already in use JVM_Bind

This means that another server is already listening on those ports. Maybe another copy of Jive Messenger? Do you have any other XMPP servers installed on the machine?

-Matt

I have no other xmpp servers running that i know of but i had tried many many differnet ones prior to finding jive so its possible some relic was left over.

It all seems to work though so it muct be getting that port eventually.