powered by Jive Software

Jsp compilation issues

Hi everybody,

I’ve been having some troubles with my jsp compilation when I’m doing development on a plugin I’m working on. I need to be able to compile jsp files on the fly for testing and I keep running into an error.

The error is:

java.lang.IllegalStateException:No java compiler available.

I’ve checked my JAVA_HOME env variable and it looks correct. I copied tools.jar to various folders I would expect to be in my classpath and none of it has worked. Any help would be appreciated.

Thanks,

-Walt
User.java (17856 Bytes)

Are you compiling your plugin against the Openfire build script?

The openfire build script works fine. It builds and packages any jsps found in the plugin directory. For development of those jsps though, I’ve installed eclipse, gotten openfire and my plugins to build in eclipse, and created some system parameters which allow me to point the web portion of the application to a folder of my choice for development. Ideally what would happen is that I could open a web browser and when I reload a jsp file I’ve changed (when I’m in dev mode) it would be compiled on the fly.

My code uses it’s own jetty web shell which gets initialized, bound to port 8080 and pointed at a folder containing jsps. Strangely enough I’ve gotten jsps to compile on the fly on one machine. I’m having serious issues on a second which I need to get working. I’ve tried the same process – copy the tools.jar file into the JRE lib folder but got nothing.

-Walt