powered by Jive Software

JVM, java_HOME and openfire startup behaviour

Hi, referring to JVM Settings and Debugging I edit my openfire data file into this:

#! /bin/sh

INSTALL4J_JAVA_HOME_OVERRIDE=/usr/lib/jvm/java-6-sun/jre/bin/java

INSTALL4J_ADD_VM_PARAMS="-Xms32m -Xmx128m -Xss128k -Xoss128k -XX:ThreadStackSize=128"

INSTALL4J_ADD_VM_PARAMS="-Djava.net.preferIPv4Stack=true"

read_db_entry() { …

I’ve set the direct path to my java installation in order to get rid of this message when i am starting openifre:

root@www:~# su openfire

sh-3.1$ /opt/openfire/bin/openfire start

testing JVM in /usr …

/opt/openfire/bin/openfire: line 64: /home/openfire/.install4j: No such file or directory

Starting openfire

sh-3.1$ nohup: appending output to `nohup.out’

But as you can see it does not work. If i comment INSTALL4J_JAVA_HOME_OVERRIDE out, the same message appears.

It seems to be not that big deal because openfire is running quite stable and finds the environment settings:

Version und Anbieter der JVM:

1.6.0 Sun Microsystems Inc. – Java HotSpot™ Server VM

Applikationsserver:

jetty-6.1.x

But i am asking mysel why i get the message "testing JVM in /usr …

/opt/openfire/bin/openfire: line 64: /home/openfire/.install4j: No such file or directory" ?

Maybe someone knows

I had to uncomment INSTALL4J_ADD_VM_PARAMS="-Xms32m -Xmx128m -Xss128k -Xoss128k -XX:ThreadStackSize=128", because with this option enabled openfire starts and raises the load up to 99% for some seconds and then stopped the deamon by itselfs. Can anyone reproduce the problem or can tell me why it’s happen that way?

Hi,

you should find errors in STDOUT / nohup.out. The Xss/Xoss values may be too small, you can try to increase them to 192k or 256k.

LG

Hi,

does your file still contain two INSTALL4J_ADD_VM_PARAMS lines like

INSTALL4J_ADD_VM_PARAMS="-Xms32m -Xmx128m -Xss128k -Xoss128k -XX:ThreadStackSize=128"

INSTALL4J_ADD_VM_PARAMS="-Djava.net.preferIPv4Stack=true"

?

The 2nd one will overwrite the settings in the 1st line, to make sense it should read:

INSTALL4J_ADD_VM_PARAMS="-Xms32m -Xmx128m -Xss128k -Xoss128k -XX:ThreadStackSize=128 -Djava.net.preferIPv4Stack=true -Dfile.encoding=UTF-8"

LG

Uhm… my fault! I have two lines containing “INSTALL4J_ADD_VM_PARAMS”

I will edit this into one line. Also i am trying to change some values: xms 512M xmx 1024M - without xss, xoss and stack because i have 2GB of warranted Ram. I think this could work out?

For some time i am running the setup INSTALL4J_ADD_VM_PARAMS="-Xms512m -Xmx1024m -XX:+PrintGCDetails -Xloggc:/opt/openfire/logs".

Today there are only 35 user online (maybe because of the good weather over here ) and my java usage is about 42% of 986.12MB. For me it seems to be quite high, isn’t it?

A few days ago i added the parameter -XX:+PrintGCDetails -Xloggc:/opt/openfire/logs as you can see above. But there is no loggin going on - any idea?

Thanks

-Xloggc:/opt/openfire/logs
Maybe this needs to be a filename, not a directory?

Oh man, i could use a break Will see if i get data the nex day.

Try editing /etc/sysconfig/openfire

Set this to the path where openfire lives.

If this is not set the script will look for /usr/local/openfire, then

/opt/openfire.

#OPENFIRE_HOME=""

If there is a different user you would like to run openfire as,

change the following line.

#OPENFIRE_USER=“daemon”

If you wish to change the location of the openfire pid file,

change the following line.

#OPENFIRE_PIDFILE="/var/run/openfire.pid"

If you wish to explictly specific the location of the log directory,

you can set it here. Note that this applies to the logs generated outside

openfire itself. If you want to change the location of openfire’s own

logs, see the system property ‘log.directory’. If this is not set,

it will default to $OPENFIRE_HOME/logs.

#OPENFIRE_LOGDIR="/some/where/logs"

# If you wish to set any specific options to pass to the JVM, you can

# set them with the following variable.

OPENFIRE_OPTS="-Xms256m -Xmx512m"

If you wish to override the auto-detected JAVA_HOME variable, uncomment

and change the following line.

#JAVA_HOME=/usr/java/default

ps -ef | grep openfire

daemon 13763 1 13 19:07 ? 00:00:06 /opt/openfire/jre/bin/java **-server -Xms256m -Xmx512m **-DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar

Hope this help.