JWchat and Openfire 3.4.5 not working

I installed the new release of Openfire 3.4.5. And I have to use this server with JWChat as I need http-binding. I have installed all the components necessary and I have installed according to the blogpost available posted by different developers. I think the way I installed and the files I configured is OK.

But when I run JWchat and I try to login I find the error “Service not implemented” and I cannot login.

And also when I directly link to http://localhost:8080/ i find the 404 not found error. Is http-binding working fine with this new release. I have used the debian linux.

Please help me.


Hello Patrik,

I didn´t try it out by myself but there is a blog entry on ‘Memory Leak’ that may help you? http://chromus.kajigger.com/blog/2007/03/22/making-jwchat-work-with-openfire/


Thank you for your reply.

I have done the configuration as shown in the link which you have posted. From different blogs I came to know that Openfire 3.4.2 onwards it doesn’t work for http-binding. So I want to try 3.4.1 version. But I am not able to find this version from the site. Can you tell me where can I find this version?

Thank you


Hello Patrik,

sorry, can´t help you with that. Let me know if you can solve the problem (possibly with 3.4.5) - I´m interested in integrating Jwchat, too.


pratikdbl wrote:

From different blogs I came to know that Openfire 3.4.2 onwards it doesn’t work for http-binding.

Are you sure it’s not just the BOSH version parameter in config.js? You need to set it to false


I am using Tomcat 5.5.26 and jre 6 update 3 from sun, openfire 3.4.4 and jwchat 1.0beta3 (installed using the war file so I use the JabberHttpBind servlet)

I can connect to openfire with jwchat but I am disconnected after few minutes with the popup “service unavailable”.

In stdout log of tomcat I have the following lines:

inQueue: </stream:stream>

:1:30: The element type “doc” must be terminated by the matching end-tag “</doc>”.

terminating session gIw8kAm0_phLVY2t_WT-Zjm_

Have you ever seen this or do you know what can be tried?


I am Facing the same error.

It seems the There might be some issue at JHB sevlet’s “Session.java”.

Trying to fix it up…


I solved my probem updating/creating a parameter in openfire configuration, it was on 3.4.4 version but it costs nothing to try the same on 3.4.5.

I will post the parameter name asap I can access the information (monday morning).

setting xmpp.client.idle=-1

solved the issue

setting xmpp.client.idle=-1

solved the issue


You found the solution before I have the time to post my update but I think it was this parameter.