powered by Jive Software

Jwchat, Tomcat and SSL

Can anybody help me with configuring Jwchat to use SSL connection?

How can I achieve that? I am using

apache-tomcat-5.5.12

jwchat-1.0beta2

and Wildfire 2.4 ,of course!

If I enable Tomcat’'s SSL option, will it secure Jwchat also? Will it affect the connectivity issue? Does Jwchat itself has an option to use ssl ?

Thanks in advance,

wmhtet

Hi wmhtet,

I personally prefer apache for SSL, and using mod_proxy to connect to tomcat, but using tomcat’‘s SSL features should yield to the same result. As long as the users use the ssl connection to login it will be secure. You’'ll see the SSL icon in the JWChat window.

The apache (v2.0) configuration is very simple, see Reverse Proxy in http://httpd.apache.org/docs/2.0/mod/mod_proxy.html

JWChat itself will still use an unencrypted connection to Wildfire, this should be no problem as you run both in one Tomcat.

LG

Hi LG

If you don’‘t mind, can you help me a bit more with Tomcat SSL? Can I use the keystore I have created for wildfire server for Tomcat? I have uncommented out the tag for Tomcat SSL connection and have given the path to Wildfire keystore. I didn’‘t change the port to 443 but use the default 8443. I still don’'t have access to the https://localhost:8443 .It is not getting any page. I have looked for solution in google and

https://www.geneticmail.com/mailgene/wiki/Wiki.jsp?page=Tomcat

tried to add the address attribute address=“xx.xx.xx.xx” but I still cannot get the page. I tried

SSLEngine=“on”

SSLCertificateFile="/somedirectory/mycert.pem"

without using keystore also but still no workee. I have looked at the documentation you have provided and it scare me ( I really haven’'t go through it yet tho but a very long page scare me. ) I want to stick with tomcat for the moment because I have it working for non-SSL session already. I know, I know, this is not a tomcat, jwchat forum. But I really appreciate the help.

Regards,

Wmhtet

hmmm…

I don’'t know why it is not working on windows. It is working in linux now.

wmhtet

Hi,

I would look at http://tomcat.apache.org/tomcat-5.0-doc/ssl-howto.html - that’'s the official tomcat SSL documentation. And also this one is very detailed. Maybe it helps you to get also the windows version running.

Actually I will not try it on my win32 system, the server.xml file contains very basic instructions, together with the Tomcat documentation SSL activation should be really painless.

LG

Hi LG

I have gone through that but some how I can’'t get it working on windows. Later I tried that on Linux with the help of linux expert, I see where I make a mistake and it work fine. But I still cannot apply that to windows side (because it is about permission problem in linux). Anyway thanks for the reply though.

regards,

wmhtet

Configuring Apache Tomcat 5.5

=============================

Purpose:

to get jwchat(tomcat) listening on port 80 which is default port for http

to get SSL working, making use of keystore from Wildfire

to auto redirect http to https

Things to know:

: tomcat has to run as root to get access to those ports (not to run as root will need different articles)

: “the auto redirect http to https” setting will prevent the user from downloading files via Internet Explorer

Change the following configuration

RELATIVE_PATH/apache-tomcat-5.5.12/conf/server.xml

Line 77 Column 22 “8080” to “80” or to be precise,

Edit non-SSL session as follow


Edit the SSL session as follow


:


Automatic SLL Forwarding

/*

CONFIDENTIAL

References:

http://www.digicert.com/ssl-certificate-installation-tomcat.htm

https://www.geneticmail.com/mailgene/wiki/Wiki.jsp?page=Tomcat

http://confluence.atlassian.com/display/JIRA/RunningJIRAoverSSLor+HTTPS

It is assumed that the user is installing tomcat on linux. However most of the instruction can also be applied to windows installation as well.

wmhtet

Message was edited by:

wmhtet

Jwchat currently does not support changing 5222 port for JWChat-1.0beta2

Here is the developer comment regarding the issue.

https://sourceforge.net/forum/message.php?msg_id=3276983

By: Stefan Strigler - zeank

RE: connect to other port then 5222

2005-08-02 11:29

Sorry for the late reply. Have been on holidays…

Neither punjab nor JabberHTTPBind nor JSJaC support connecting to a jabber server other than the default port at the moment. I’'ll release fixes to this problem soon (the underlying JEP for HTTP Binding had to be modified to make this work in the first place - now that we have this modification I can go on implementing it).

I have configure Jwchat not to show the server to connect to and to hide check box for creating a new account. It is a preferable soultion if you have your own jabber server and user base which you have imported, for example, from Ldap. I don’'t know html css and Js at all, so let me know if my configuration is having an affect on the performance. The only thing I have done is Commenting out some code. I have also put my name where I do that as much as possible. I will be posting the file in the next reply, I have check the preview of the posting and it is not looking good because the forum make use of the html code and things got confused. I hope the forum mod will make it plain text only.

Last modified: Fri May 20 15:10:14 CEST 2005

/code

Message was edited by: wmhtet

Message was edited by: wmhtet

Had I only had “Attach file” option

Well, of course, it is assumed that you have edited config.js for default server.

Message was edited by:

wmhtet

JWChat with HTTP Binding servlet, Tomcat, Apache using mod_jk by Op3racional

http://www.blochberger.de/en_jwchat_how_to.htm

Thanks LG!!!

For Actual code

How ignorant of me not to know that

Thanks again

wmhtet

Message was edited by: wmhtet

Hi wmhtet,

you may also post [code] Actual code if you’'d prefer red color (:

LG