powered by Jive Software

Keyboard IME value fixed in English when chat window opened. How do I fix it in another language?


#1

Keyboard input changes when you open chat window.
If you convert it and write it well, it will be written in English.

I would like to modify it in the source, please let me know.

spark is version 2.7.7.


#2

I don’t understand what you mean. Please explain it again and maybe with some examples. Btw, current version is 2.8.3 (and latest source is 2.9.0). Do you really need to modify 2.7.7 source?


#3

When you click the chat window, the language set is automatically changed to EN (English), so you have to press the keyboard conversion key every time.

Is there a way to fix the keyboard language when loading a locale set of languages or opening a chat window?

Or you can tell me where the source is set to EN when the chat window opens.


#4

It works ok for me on Win7 with 2.7.7 and the latest nightly build. It uses another language (not EN) which is set as default. I think i remember (vaguely) someone having similar problem in the forums like 5 years ago, or maybe even i have seen this myself, but i don’t remember any details. Maybe it wasn’t even with Spark.

I don’t think there is a place in the source setting that, otherwise it would also always pick EN for me. And it doesn’t seem logical to hardcode such thing. This looks like some OS/region/Java related glitch, but it would be hard to pinpoint the actual cause.