powered by Jive Software

Keytool error: java.lang.Exception: Alias <mydomain> has no (private) key

After experiencing numerous problems trying to add an SSL through the Admin site, I turned to Keytool. I’m trying to start with the self-signed certs provided by Openfire as it does not seem inclined to accept any pre-existing certs I’ve tried to import. I’m able to import the signed certificate in Keytool, but when I try to view the cert in Openfire, I receive the error:

Exception:

java.security.InvalidKeyException: Supplied key (null) is not a RSAPrivateKey instance…

When I go into Keytool and try to change the private key I get the error: keytool error: java.lang.Exception: Alias has no (private) key

I found a similar thread here at http://www.igniterealtime.org/community/message/192315#192315 and the poster answered his own question, but his method has not worked for me. When I try to load the cert by that method I get a generic error in Openfire saying: Unable to access certificate store. The keystore may be corrupt.

Any suggestions anybody can provide would be very much appreciated.

Thanks!

-Kyle