powered by Jive Software

Kicked from chatroom

My co-workers and I were having a chat conversation and out of a sudden 8 people got kicked leaving just 3 of us in the chatroom. No one kicked anyone. Why did this happen? I am using the latest release with Exodus clients.

Very strange… did people get entirely kicked from the server or just from the group chat room? If you see this again or can come up with any extra clues about what happened, please let us know. We can try to setup some extra load tests for keeping people connected for long periods of time.

Regards,

Matt

Matt, thaks for your swift reply… here’'s more detailed info:

I created 4 permanent chatrooms, we all joined one, like 9 of us, then out of a sudden after 15 minutes like 6 got kicked out, leaving 3 of us there. Then 4 rejoined and after 10 minutes got kicked out again. I (the creator of the room) have not being kicked out yet. And there is one person left in the room with me, I will wait until that person is kicked out and see the timeframes of when they joined and when they got kicked. To answer your question, they only get kicked out of the chat with the message " has been kicked from this room."

I am running Jive 2.0 in a Fedora machine.

We’'ll try to reproduce this issue and will let you know what we find.

Thanks,

Matt

zgambitx,

The MUC service has a process that kicks idle occupants from all the rooms where the user had joined. The default configuration is to wait for 30 minutes. By idle occupant I mean occupants that didn’'t send a message to the room for a while. Owners cannot be kicked.

For now it’'s not possible to configure the kicking process through the admin console. Though we are planning to add that feature. Anyway, you can configure it by creating or editing the value of the property directly in the database.

You need update the jiveproperty table and set name=xmpp.muc.tasks.user.idle and propValue=[milliseconds to consider idle]. If you set propValue=-1 then the whole feature will deactivate.

Let me know if you are still having problems.

Regards,

– Gato

Gato,

I cannot find the property table of xmpp.muc.tasks.user.idle under JiveProperties.

Thank you,

zgambitx

nvm, i created the actual row. thanks gato!

Gato,

Didn’'t work. I created the row and added the value of 1.

this is the log from the actual chatroom, notice the timestamps and yes I restarted the server after updating the mysql db.

\cf1 \cf2 cserpa has joined the room\cf3\par

\cf1 \cf2 This room is not anonymous.\cf3\par

\cf1 \cf2 tlango has entered the room.\cf3\par

\cf1 \cf2 tlango has joined the room\cf3\par

\cf1 \cf4 \cf3 I joined\par

\cf1 \cf5 \cf3 ok just idle here\par

\cf1 \cf4 \cf3 k\par

\cf1 \cf2 tlango has been kicked from this room.\cf3\par

zgambitx,

The value of the property should be -1. Using 1 means that if the user didn’'t send a message to any room in 1 millisecond then he will be kicked.

Let me know if -1 solved your problem.

Regards,

– Gato

Mr Gato -

It has seemed to work. I changed the value to -1 and I left 2 clients on that were not owners and were not kicked out.

Thank you pibe!

Is this value changed in 2.01? I have tried setting the property xmpp.muc.task.user.idle to -1 and I am still having users kicked from a chatroom every 30 minutes if they are idle.

Couple of suggestion:

  1. Make sure that the property doesn’'t have any spelling mistake. It should be: xmpp.muc.tasks.user.idle

  2. Since you are setting/modifying the property manually you will need to restart the server so that the change will be taken

  3. Or you may download the latest nightly build and just use the provided UI.

Regards,

– Gato

Thanks Gato. It looks like it is working now. I must have had a typo somewhere.

Rich