powered by Jive Software

Kopete authentication trouble / Howto configure kopete

Are there any special tricks for configuring the Kopete (KDE chat client) to connect to an OpenFire server? I know that I have read that people are doing this sucessfully, but trying to configure my client to connect to a friends OpenFire server, I always receive an authentication error. I use this same copy of Kopete to talk to jabber servers such as Gmail and LiveJournal. I am running Kopete from KDE 3.5.7 .

If SSL is enabled, or disabled, I get an “Login failed for unknown reasons” error. (w/SSL, this happens after accepting the SSL certificate)

The username created for me was ‘leah’ and let’s say the server is ‘mail.example.com’ . When you go to configure kopete and add a new account, selecting Jabber for the protocol, first it wants the username. I have tried ‘leah@mail.example.com’ (it will not let me put in just leah). I also had my friend create me an account called ‘leah@example.com’ and have tried with that too. Both can connect in using Spark.

I then put in the password, and select the connection tab, and make sure that ‘mail.example.com’ is input for the server. I have tried variations here for other connection settings. The default is “Use protocol encryption” and “Allow plain-text password authentication”. The port is set to 5223 if SSL is turned on. It is 5222 w/o SSL turned on.

Am I missing something here, should I be trying a different port, or are there known issues w/this version of Kopete, or some versions of OpenFire? My friend’s openfire server version is 3.3.3

Thanks so much for your assistance.

Leah

Have you tried the Spark client to connect to the server to verify you can hit it? This will eliminate the possibility of it being a networking issue if it works. Your settings in Kopete seem reasonable, but without looking at error logs or network traffic, it is very hard to trouble shoot.

I just installed Kopete 3.5.7 on my Debian box and had no issues setting up the account on my openfire(3.3.1) server using SSL. The only thing I saw was an alert stating that there was a self-signed cert coming across and should I continue. It sounds like there might be something with your ability to access the server in general.

I had a similar issue just recently trying to use Kopete 0.12.6 on KDE 3.5.7, and it seems to be the same as yours. After the Kopete login failure message, I took a look at the Openfire server logs, which turned up this warning…

2007.10.12 20:06:40 User tried to authenticate with this server using an unknown receipient:

<iq type="get" id="auth_1" to="example.com" from="link.example.com/10c9b20f">
<query xmlns="jabber:iq:auth">
<username>zelda</username>
</query>
</iq>

Effectively, this is saying that my username is unknown because it doesn’t really match the server name. Incorrectly, like this:

server = link.example.com

username = zelda@ example.com

Google chat allows this difference (requires it), but it’s probably not allowed on your friend’s Openfire server. So, get the official name of the server from your friend, (check the Openfire Admin Console under Server Settings for the “Server Name” value), and use this for BOTH the server name and username after the @. You may need to delete the existing account in Kopete and create a fresh one. In Kopete, these are the settings that worked for me:

Jabber ID: zelda@ link.example.com

Use protocol encryption (SSL): (checked)

Allow plain-text password authentication: (checked)

Override default server information: (unchecked)

Server: link.example.com (set automatically)

Port: 5223 (set automatically)

Brett