powered by Jive Software

Latest nightly builds break broadcast and search plugins

Both the 2005-04-13 and the 2005-04-15 nightly builds seem to break the broadcast and the search plugins.

When the server starts, it creates both the \broadcast and \search directories correctly. Each directory looks as if it contains the correct files (plugin.xml, \lib directory, etc…), however the plugins don’‘t show up in the plugins page of the admin console. Also, the search plugin doesn’'t work within Exodus with the above nightly builds.

Hey,

Sorry about that. The Component API has changed and the jar files available for download have not been updated. I will try to have them updated today and let you know when you can download them. So all you will need to do is install the new jar files in the plugins folder .

Regards,

– Gato

I have attached the jar files to this post so you can download them from here. For now I don’'t think that updating the jar files in the download page is a good idea since other people may be still using Jive Messenger 2.1.2.

Regards,

– Gato

Just an FYI, the search.jar that Gato just posted is version 1.0.6 and has the revised UI that was discussed url=http://www.jivesoftware.org/forums/thread.jspa?threadID=14410here[/url].

Thanks,

Ryan

Thank you very much. I really appreciate the quick response.

Great software BTW.

Our organization is about to set up a possible 1000 user test deployment, if it works as good as we expect, the number of users could go much higher.

Thanks again!

Hi,

I downloaded the latest nightly build and tried to install the attached plugins, however they don’'t appear in the admin console.

Any suggestions?

pow12

pow12,

We’‘re just about to release Jive Messenger 2.1.3 and will officially publish the new plugins then. I’'m not sure what might be going wrong with the nightly builds, but that would be a good, tested configuration.

Regards,

Matt