powered by Jive Software

Latest Spark version from SVN

Latest (daily builds) version of Installer4J variant can be found at:

http://bamboo.igniterealtime.org/browse/SPARK-INSTALL4J/latest (go to Artifacts tab, press install4j link and download first exe version, don’t mind the build number, number is old, but the build is of the revision which is mentioned on the Build page)

**Important to know: in the current SVN version user’s profile path has been changed from \Username\Spark to \Username\Application Data\Spark (Windows XP) and \Username\AppData\Roaming\Spark (Windows Vista and 7), **~/.Spark/ changed to $HOME/.Spark (Linux).

Please use the RC2 from nightly build.

Tried to install this on my mac, I get ‘/applications/spark/start no such file or directory’

You have immediately found the weak spot of the community development. We are weak on Mac developers. There is a known issue for Mac, but neither cstux nor my dev team is able to fix it.

I am trying to install it on Vista SP1 but the installer wizard is giving me an error on the step to select the installation folder. Could not proceed any further! It works fine though on XP SP3.

I welcome the added settings for the taskbar flashing and group chats. However I still can’t find a way to disable/suppress join and leave messages from group chats. Please let us know if there’s a way.

Thank you.

Yeap, seems that IzPack installer cant create a folder in Program Files when UAC is enabled (same with Windows 7).

pbezztell, try priviledged.jar

priviledged.jar worked well. Thanks. This version can also co-exist with 2.5.8 which is useful for me.

I would like to know if in this beta version there’s a way to disable or suppress join/leave messages from the group chats.

There is no such option. I can only create a ticket for that SPARK-1057.

We had the same requirement due to a Openfire extension we are running. I’ll ask the programmer to create a patch for that and submit it to cstux.

I am having difficulties getting this version to launch on system startup (used the privileged jar)… could this have something to do with registry entries of previous spark versions?

would highly appreciate that Walter. when do you think the patch will be available please?

wroot is not a all-knowing person i think cstux can comment on this better. So far i can only test with Windows 7 RC and i’m having problems launching Spark manually after a restart. Somehow javaw process is hanging and Spark is not showing up. Maybe i will try to install Vista later to test that.

cstux: It seems like I’m able to delete all comments on this page, intended?

Wroot: I’m also running Windows 7 RC, I’ll try on a clean XP and post the results.

cstux didnt set the permissions. site admins has changed something, but they think that only contributors has all powers

So, start on system startup isnt working on Vista too, but at least there is no problems with launching Spark on Vista. With Windows 7 RC i’m only able to launch it after installing. After a restart the process is just hanging but GUI is not showing up.

Hey, great work, nice to see that someone cares about new Spark installers

But I dont get the diffence between the priviledged and non priviledged version.

And is there a list of installation parameters?

It seems that izpack offers an autoscript, but i dont get how set it as an parameter to the installer.

Best regards,

Maddi

Priviledged version is for the systems with limited rights default user (no admin rights). You cant normally install simple version to Program files on Vista with non-admin user, as simple version won’t provide UAC privilege elevating dialog. Similar problems could be on linux system using sudo command.

Walter can you tell me when the patch for the option to suppress join/leave messages will be available please? I am eagerly waiting for it …

i tried the installer on a vista 32 bit sp1 and i have some troubles with the trayicon. It is a bit too large so it is cut on the edges and it is not showing the actual status (away and so on) After first install i had zwo trayicons. one normal with status icon’s and the bigger one without any status-changes. I uninstalled all previous versions and deleted all sparkfolders. after that i installed clean with your installer an now i only have the big trayicon.

The issue about not showing the actual status in the tray is fixed in 11044, but it’s not uploaded here yet. Can you make a screenshot of this big systray icon?