powered by Jive Software

Launch on Startup

v2.5.8 (newbie w/Spark too).

Launch on Startup creates C:\Program Files\Spark\KYWINS.exe in user’s Run key.

KYWINS?

TIA

My install only shows spark.exe. Could you include a snapshot of the reg entry? How was your software installed, and was it a standard un modified installer file?

Standard install via Group Policy (spark_2_5_8.msi).

Thought it was a joke (Kentucky wins?) but no hits on Google about this anomaly…

thanks

1/9- checked on another PC, same thing. Server is W2k3 R2, workstations WXPPro SP2.

Kentucky wins…hehe (at least against LSU). That is way cleaner than my first thought. Anyway…

Does that exe actually exist? Are you using an unaltered msi installer from ignite? Try an uninstall on one of the machines, delete residual directories and install the software using the exe. If that fixes it, there could be an error in the msi installer file. That would need to be looked at by Daniel.

No the exe does not exist. It must be tied to the msi file.

I tried the msi w/o java and it is the same.

Just for giggles try the EXE installer: http://www.igniterealtime.org/downloads/download-landing.jsp?file=spark/spark_2_ 5_8.exe

ok, tried the exe - not an issue there - default install sets to auto-launch (unlike the .msi) and the path is correct (Spark.exe vice KYWINS.exe).

So, both msi’s have some sort of wierd issue???

Huh. Ok, so, I downloaded and installed via the MSI installers and no KYWINS.EXE. Tried a number of iterations. I also can’t find the string KYWINS.EXE in the binary at all. Don’t see any reason why it would be caused by the MSI installer from this site. So… I’m a little concerned that something else is going on in your environment that is causing that.

Yes, all sounds a bit strange. I too had searched for the KYWINS sring with no luck. Did a Google for KYWINS and found this: http://kwiec.ky.gov/interoperability/KYWINS.htm and

http://209.85.165.104/search?q=cache:fcrDkas85NkJ:kwiec.ky.gov/NR/rdonlyres/1155 A97D-DEAC-4488-A2F0-46A64CED1FF4/0/KYWINSMessenger_FAQ.doc+KYWINS&hl=en&ct=clnk& cd=2&gl=us

The plot thickens…

No comments/opinions on those links?

Not on those links, but in investigating an unrelated thing, I’ve located a number of copies of KYWINS.exe in the location where we store automatic Spark updates. So that’s the clue I need I think, going to ask around internally to shed some light on this.

just a fyi, i also have the same problem. i use the msi for distribution via gpo. spark creates a reg entry pointing to kywins but there is no such file in the spark directory. using 2.5.8

Me too, installing via GPO executable is KYWINS.EXE and doesn’t exist, so launch on startup just doesn’t work. Anyone ever fix this?

I found the same issue when installing from the MSI. As a workaround I just manually edited the registry entry on my PC then exported itl and added it to my domain workstations startup bat.

If not exist “C:\Program Files\Spark” GOTO END

REGEDIT /S \\NETLOGON\spark\run.reg

:END

The run.reg file looks like this

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
“Spark”=“C:\Program Files\Spark\spark.exe”

Ended up writing it into VBS logon script but it’d be nice if worked, and if other settings were in registry so they could also be set via GPO. (I know I could copy the settings file but I donlt want all the same.)

WSHShell.RegWrite “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run\Spark”, 1 ,"REG_SZ"
WSHShell.RegWrite “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run\Spark”, “C:\Program Files\Spark\Spark.exe” ,“REG_SZ”

Found the source of the KYWINS.exe problem, but not how to fix it (I’m not good at editing .msi files).

The problem is in the spark_2_5_8.msi but not the .exe installer.

In the spark_2_5_8.msi there is a spark.jar file (these are .zip files for java).

In the spark.jar file is a file called default.properties (org/jivesoftware/resource/default.properties).

In this default.properites file it says:

SHORT_NAME = KYWINS

In the spark.jar file from the .exe it says:

SHORT_NAME = SPARK

That is the name that ends up in HKCU\software\microsoft\windows\currentversion\run

Can anyone tell me how to replace the spark.jar file in the .msi file? I don’t know how…

I am also having this same exact issue. Got arround it by adding spark.exe to “c:\Documents and Settings%username%\Start Menu\Programs\Startup” folder.