powered by Jive Software

LDAP as auth backend - Invalid DN Syntax

Hi dears…

I’'m using jabberd2 for now, but are in final stages to migrate to Jive Messenger, but a litle inconvenient are stopping my work…

I need LDAP as my auth backend, this is my configuration:

But when I try to acces the admin, or connect via client (Psi), this error is caught:

2005.10.19 16:26:39 Trying to find a user’'s DN based on their username. cn: qlx, Base DN: ou=USERJFSC,o=JFSC…

2005.10.19 16:26:39 Creating a DirContext in LdapManager.getContext()…

2005.10.19 16:26:39 Created hashtable with context values, attempting to create context…

2005.10.19 16:26:39 … context created successfully, returning.

2005.10.19 16:26:39 Starting LDAP search…

2005.10.19 16:26:40 … search finished

2005.10.19 16:26:40 In LdapManager.checkAuthentication(userDN, password), userDN is: ldap://ldap.jfsc.gov.br:389/cn=QLX,ou=NINF,ou=FLP,o=JFSC…

2005.10.19 16:26:40 Created context values, attempting to create context…

2005.10.19 16:26:40 Caught a naming exception when creating InitialContext

javax.naming.InvalidNameException: LDAP: error code 34 - Invalid DN Syntax

I have no idea what can be…

Any idea?

Regards

by qoelheXXIX

This caught me too - I figured I’‘d missed some documentation somewhere. Maybe it wasn’'t just me. The BaseDN attribute uses semicolons as separators, not commas. In your example:

Should work. That did it for me.

unfortunately don’'t work for me :(…

And in Apache, in the same machine, the ldap auth is ok!

by qoelheXXIX

Just from having a close read of the logs (this is pure speculation) and seeing that “Invalid DN Syntax” note, check that “cn” actually is the proper key for the user DN. I don’‘t know what kind of LDAP server you’‘re talking to, but most commonly you’'ll find the attribute “uid” is used to construct the DN.

My (working) config is:

I think it is a bit strange too, but is because this ldap is a gateway to a Novell Directory, that export your records in a diferent manner…

By the way, just for testing, I change cn to uid, and the error becomea little diferent,but not a better error…

2005.10.20 15:15:18 Trying to find a user’'s DN based on their username. uid: qlx, Base DN: ou=USER;ou=FLP;o=JFSC…

2005.10.20 15:15:18 Creating a DirContext in LdapManager.getContext()…

2005.10.20 15:15:18 Created hashtable with context values, attempting to create context…

2005.10.20 15:15:18 … context created successfully, returning.

2005.10.20 15:15:18 Starting LDAP search…

2005.10.20 15:15:18 … search finished

2005.10.20 15:15:18 User DN based on username ‘‘qlx’’ not found.

2005.10.20 15:15:18 Exception thrown when searching for userDN based on username ‘‘qlx’’

org.jivesoftware.messenger.user.UserNotFoundException: Username qlx not found

Regards from Brasil

by qoelheXXIX

I am facing same problem.
Invalid DN syntax or naming violation
I have AD on my other server.
For example test.co.in
Base DN: cn=Users, dc=test, dc=co, dc=in
I also tried
Base DN: cn=Users; dc=test; dc=co; dc=in

Administrator DN:
cn=Administrator,dc=test, dc=co, dc=in
I also tried
cn=Administrator; dc=negd; dc=co; dc=in
Administrator Password: *******

I am doing above setting but when I test the setting it give me error. Is there any others logs except this error message where I can see the actual cause.
Please help.