powered by Jive Software

LDAP Assistance

I’m trying to setup Spark to use the LDAP function to search for users on the server. Openfire Admin Console returns all the users in the Active Directory (Windows 2000) however, when using Spark to search for the users, I get an “Unable to contact Search Service”. Could someone please assist?

Also does anyone know if its possible to add all users to everyone’s friendslist at once, rather than having to add one user at a time?

Thanks again

bump

Could someone please assist me with this as I would really like to try and get this up and working before the week is over.

Many Many thanks

You need to install the search plugin on Openfire server. Once installed you need to enable it and configure it for access by the client.

Thank you very much for your reply Todd.

Could you point me in the right direction of some documentation so that I can configure the plugin to search our LDAP Directory please?

Again, many many thanks

If the server is using LDAP to get users then the search plugin should search your LDAP by default.

I’ve uninstalled and re-installed the plugin for searching, but the spark client still gets a “Unable to contact search service”. I’ve checked the admin console, and the service is turned on. I can use the admin console to search for the users in the LDAP directory, but when I try to use Spark I get the message above…

Any ideas?

Are there any logs on the server from when you try to do a search? You can clear the logs first then do a search to narrow the log file. The debug logs generally would show the error. Also are there any errors in the spark logs? Does the service name match the name of your server (i.e. search.somedomain.com)?

This is the error in the Spark log when I try searching for a user…

service-unavailable(503)

at org.jivesoftware.smackx.search.UserSearch.getSearchForm(UserSearch.java:78)

at org.jivesoftware.smackx.search.UserSearchManager.getSearchForm(UserSearchManage r.java:67)

at org.jivesoftware.sparkimpl.search.users.SearchForm.<init>(SearchForm.java :55)

at org.jivesoftware.sparkimpl.search.users.UserSearchForm.showService(UserSearchFo rm.java:177)

at org.jivesoftware.sparkimpl.search.users.UserSearchForm.<init>(UserSearchF orm.java:76)

at org.jivesoftware.sparkimpl.search.users.UserSearchService.processQuery(UserSear chService.java:72)

at org.jivesoftware.sparkimpl.search.users.UserSearchService.access$200(UserSearch Service.java:37)

at org.jivesoftware.sparkimpl.search.users.UserSearchService$1.finished(UserSearch Service.java:55)

at org.jivesoftware.spark.util.SwingWorker$2$1.run(SwingWorker.java:136)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

07-Nov-2007 13:57:57 org.jivesoftware.spark.util.log.Log error

SEVERE: Unable to load search services.

Has anyone experienced this problem when trying to search LDAP?

I get this message when I try to use the search bar at the bottom of the Spark Client.

I can log in and this won’t give me a problem, only when I try to search.

Could someone give me an update please?

Many thanks

EDIT: I’ve also started to get the following message when trying to connect to the conference service.

08-Nov-2007 09:59:38 org.jivesoftware.spark.util.log.Log error

SEVERE: Error in disco discovery.

remote-server-not-found(404)

at org.jivesoftware.smackx.ServiceDiscoveryManager.discoverInfo(ServiceDiscoveryMa nager.java:413)

at org.jivesoftware.smackx.ServiceDiscoveryManager.discoverInfo(ServiceDiscoveryMa nager.java:379)

at org.jivesoftware.spark.ui.conferences.BookmarksUI$12$1.construct(BookmarksUI.ja va:418)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:129)

at java.lang.Thread.run(Unknown Source)

Hopefully someone can help :-s

Thanks

Can you try running spark on the same machine that Openfire Server is loaded on. Then try a search. I am trying to rule out OS issues (firewalls, etc).

We’ll I’ve uninstalled and re-installed the client on the server, but whenever I try to log in to it, it just kicks me out…

I have stopped and started the server, and then tried to log in, but that didn’t work.

I’ve tried uninstalling the client and reinstalling the client on the server and it doesn’t work.

But I can connect from other machines on the network :-s

Ok lets get some specifics:

  1. What is the OS of the server

  2. What if any firewall are you using on the server

  3. What is the Client OS

  4. What if any firewall is on the client

  5. What is the version of Openfire

  6. What is the version of Spark

1). Windows XP

2). None

3). Windows XP

4). None

5). Openfire 3.4.1

6). Spark 2.5.7

Since you are running everything on windows XP it has a built in firewall. Is that enabled on the machine running Openfire? If it is turn it off and try again.

First thing I checked was that, and they were already off.

Have tried anyway and still had no luck ¬.¬

Worth uninstalling and reinstalling the server?

If that is an option. I would say uninstall remove any remaining directory. The server should be bound to AD using the name you wish the server to have (i.e. chatserver). This will add the server to your AD DNS as chatserver.somedomain.com. Be sure to use this FQDN during the server setup.

Now that could be the problem. I didn’t use a FQDN when setting the server up.

I just used the local machine name.

I’ll give that a go now and let you know

Thanks Todd

Todd, your a genius.

Anyone reading this thread please make a note, if you wish to use the system on a network to include the FQDN (fully qualified domain name) of the machine you are installing the server on as this does make a big difference.

Thank you very Todd. After I had installed it I tested it on my client end and I can search the directory. Spark won’t run on the server, but I don’t need it to, so it won’t be a problem.

Thank you very very much