powered by Jive Software

Ldap configuraion issues

I am performing the initial setup for Open fire, and having issues on the User Mapping portion of the setup. Getting the error “No Users were found using the specified configuration. Try changing the base DN, user filter, or username field”

I am using all defaults (though I have read a lot of these forum posts and tried a number of things suggested, but to no use). My test on the previous page of connection settings comes back as successful. Not interested in sorting by groups, just want to find the users.

Active Directory structure is like this…

Companyname.com

–Comp Users

–Test Users

Base DN from connection settings:

ou=Comp Users,dc=companyname,dc=com

Admin name I assume is correct, as the test completes, but it is in DN form:

cn=administrator,cn=users,dc=companyname,dc=com

On the User mapping page everything is default and unfiltered.

At this point I would be happy if it would pull any users, but of course, I want to get the ones in the test OU if I can (for testing).

Also…

I notice that it is trying to pull items like Birthday, Avatar, and Nickname? I dont think Active Directory has any of these fields. Is that a problem?

Thanks in advance

Okay, Not sure why this worked, but I uninstalled and reinstalled Openfire for about the 12th time and it worked. I got it connected into AD they way I was wanting and pulled all the info I needed. Guess this one is closed.