powered by Jive Software

LDAP configuration errors

I am trying to use LDAP with wildfire. I am using openldap. I did configure the wildfire.xml and th server is running fine but I am not able to log into any account, not even admin. I am very new to LDAP and its assosciated concepts.

My first question is–does openLDAP import the users from the HSQL embedded database of wildfire automatically or do I need to create users in LDAP manually??

Secondly, I personally feel that there could be something wrong with baseDN, which is why I might be getting problems…How do I find out the baseDN(including parameters like ou etc)??

The idea behind using LDAP is that the users will allready be there from some other purpose (Active Directory, or another Unix implmentation). Wildfire treas LDAP as read only, so after switching to an LDAP backend, all your other users will be gone.

Do you have accounts set up in LDAP already?

First of all thanks a lot.!!

I thought it might import them. No wonder it never worked.

But since I am totally new to LDAP, how can i create these accounts?? I mean commands for openLDAP will be available everywhere but how do I know which file to create, which directory etc???

Thanks again

Akshaya Srivatsa

Hi Akshaya,

may I ask why you want to use LDAP?

It is usually very easy to install but when it comes to setup (dn, users, groups, rights, SSO, …) you may hit some problems. Maybe one can give you a short LDAP administration training … Imho you better stay happy and away from LDAP.



Ya you are right.Now its getting on my nerves cuz troubleshooting is very tough here. Considering I dont have any knowledge about this, it makes things worse…

But I need to work on this because this is my project topic in my college… So I dont think I have options here.

Anyways I plan to read up openLDAP documentation. Do you have any other suggestions about good places to start learning from???


Akshaya Srivatsa

Hey guys

I got openLDAP working with wildfire and let me tell you,

the documentation of openLDAP is quite bad. Too too too many syntax errors.

Anyways got it working afer a lot of effort…

Thanks anyways to everyone…

Keep the good work going…

Akshaya Srivatsa

Thanks everyone…