Ldap enclose DN Problem


I like to use openfire since 3 years and now I figure out where my problem is located.

I can’t log in a user with spaces in userdn. I tried both encloseDNs false and true. But it doesn’t work at all.

With enclosed dn false:

“CN=“ck, Bn”,OU=“IT Services”,OU=“C Services”,OU=“IT / Engineering”,OU=“foo bar””,OU=city,O


With enclosed.dns true:

“CN=“ck, Bn”,OU=“IT Services”,OU=“C Services”,OU=“IT / Engineering”,OU=“foo bar””,OU=“city”,OU=“SITES”,OU="#KONFIGURATION",DC=“company”,DC=“de”…

So when it’s set to false elements with spaces gettings quotes anyway. That is the problem, the login does not work with that.

Also a problem the double quotes to the user dn and without quoting the base?!

I can login with a DN without spaces and with enclosed.dns true without any problems.

Any idea?

Okay, seems to be a problem since 2008:

Openfire LDAP Quotation (encloseDNs) Problem and Fix.

It’s a pity :frowning:

I tried to compile it with the workaround as described in the post, but it still doesn’t work.

The interesting thing is that the admin credentials are not in quotes and working fine, but the userdn are enclosed excepting the base dn.

In addition I tried to set ldap.encloseuserdn to false, but it have no effect.

anyone up for testing this with the current release (3.10.3). I’m able to sign in using an AD username that includes a space, “test pilot”. I was able to sign-in without any problems using with both enclosedn set to true and false.

Is this still an issue?