LDAP Error When Connecting to SBS 2003

I have been trying to connect to my SBS 2003, but when I test the connection, I get the following error

[LDAP: error code 1 - 00000000: LdapErr: DSID-0C090627, comment: In order to perform this operation a successful bind must be completed on the connection., data 0, vece

I have created a user account for searching the AD called openfire.

Here are my settings:

Host: localhost (Server is on domain controller)

Base DN : OU=SBSUsers, OU=Users,OU=MyBusiness, DC=Company, DC=Engineering, DC=local

Administrator DN: openfire@company.engineering.local

I have used these credentials with LDAP Administrator with no problem. Any Ideas?

I also tried “cn=openfire,OU=SBSUsers, OU=Users,OU=MyBusiness, DC=Company, DC=Engineering, DC=local” with no success.

try changing localhost to the actual name of the Domain Controller, i.e. domaincontroller.domain.com

I tried that, no luck

does your server require ssl connections for LDAP authentication?

The server does not require an ssl connection.