powered by Jive Software

LDAP Initial Setup - HELP PLEASE!

Like many others, I have almost gone insane trying to set up LDAP for Openfire. I’ve tried to simplify everything many test accounts. I am a newbie at LDAP and novice with AD. Any assistance provided would be much appreciated.

Attached is a picture of our AD. I’ve created a test domain (datest) and user (rotest) account under the container Users. I left everything default under Advanced Settings, User Mapping, and Group Mapping. Below are my entries for the required fields.

Base DN: cn=users;dc=precheck,dc=com

Administrator DN: cn=datest,cn=users,dc=precheck,dc=com

(When I hit Test Settings, it doesn’t do anything. Just appears to refresh the screen)

On the Administrator Account page, when I type in rotest, Add, I get the following error.

ERROR: No username was provided or the specified username was not found.

In the Openfire App box where the service runs, I get the following error along with a bunch of other garbage.

LDAP: error code 49 - 80090308: LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 52e, v1db1

change your base DN to dc=precheck,dc=com (assuming that is what your DN really is) and use the ldap search filter to match on objectCategory=user.

I changed Base DN to what you stated and I’m assuming the LDAP search filter is on the User Mapping form under Advanced Setting>User Filter:? Do I replace the current default (objectClass=organizationalPerson) or add to it? Thanks!

Current default is probably good.

Thanks for the assistance but it still doesn’t seem to work, either the default, replacing it, or adding to it. Any other suggestions? Do you know what the “Test Settings” is suppose to do anything? Thanks!

Can you post all of your LDAP settings? I am using ‘objectCategory=user’ as a filter, so maybe try that? Do you see anything in the Openfire error logs when you try to search for a user? Do you get the same error after you updated the base DN?

I believe ‘Test Settings’ is broke in 3.8.1.

Can you post all of your current LDAP settings (or just the ldap.* stuff out of system properties)?

https://dl.dropbox.com/u/3294355/PreCheck/adsi.jpghttps://dl.dropbox.com/u/3294355/PreCheck/step1.jpghttps://dl.dropbox.com/u/3294355/PreCheck/step2.jpghttps://dl.dropbox.com/u/3294355/PreCheck/step3.jpghttps://dl.dropbox.com/u/3294355/PreCheck/error.jpg

I’m not sure if this is what you meant by LDAP settings but if not, please specify how I get that information. I attached screenshots of the setup filled in as suggested and the error log from the Openfire App box. There are no errors in the error.log. Again, thank you so much for your help. Thanks!

LDAP error 49 indicates your credentials for bind are incorrect - Did you make sure you got the password right for cn=datest?

You might want to install openldap so you can test the ldap queries from the command line and make sure it works properly before you configure Openfire.

try using datest@precheck.com

Thanks all, looks like a combination of the suggestions or just the last one worked.