powered by Jive Software

LDAP Not Binding to Administrator DN

I’‘ve been having LDAP install problems since Wildfire 3.0.1. I’‘m still having problems configuring LDAP on 3.3.0. Wildfire can talk to the LDAP server. I get all the way to the part where the setup process asks for me to enter a LDAP user for admin access. When I test that user, I get authentication failed. We’‘ve compared it to apps that do work with our LDAP server, and our LDAP administrator tells me Openfire doesn’'t seem to be binding with the Administrator DN. Is there any more debug output that I can provide? If so, how can I get that data? Thanks.

Are you trying to bind to username or CN=User,DC=users,DC=example,DC=com

I ran into that first time I setup wildfire/openfire your best bet is to go get softerra’‘s free ldap browser and pull the user context filed information. That’'ll give you the true administrator DN to bind to for the ldap read.

Thanks for responding. I’'m trying to bind with the Administrator DN that our ldap admin assigned to me, which looks like uid=adminuser,ou=services,dc=mydc. The Administrator DN works in other applications.

I tried the Softerra tool, but it doesn’'t appear to do ldaps, which is required by our ldap server.

If your on a windows 03 network CN would be the correct format. If your using another ldap provider then I’‘m not sure on that. The ldap browser from softerra should work, that’‘s all it does is read ldap tree’'s. That leads me to believe something is incorrect in the information your admin is giving you.

This thread describes how to fix the problem I was experiencing. This should really be in the doc somewhere, or automagically accounted for during the install process.