powered by Jive Software

LDAP setting all fine - but nothing in Spark

Hello everyone,

This morning I have been working to reconfigure our OpenFire server after something that was installed last week took it down. (Long story, don’t ask) Anyway, I got all three steps of the ldap config to work perfectly and all three points give me a green “Success!” sign. However, when I log into spark no one shows up.

The way I am trying to set this up/ had it setup before, was that OpenFire was looking at a Security Group that listed everyone I wanted to have access to Spark in it. However no one shows up anymore in Spark. (Am I making any sense?)

I’m pasting the XML file below (with passwords removed) if you could glance over that and tell me what you think that would be great. Or if you happen to have any ther ideas and or questions I would GREATLY appreciate it. People around here have really come to rely on IMing accross the office.

~Ben


openfire.xml-----

<?xml version=“1.0” encoding=“UTF-8” ?> -

<jive> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <adminConsole> -

<port>9090</port>

<securePort>9091</securePort>

</adminConsole> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <admin> -

<authorizedUsernames>ben</authorizedUsernames> </admin> <locale>en</locale> -

file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <connectionProvider>

<className>org.jivesoftware.database.EmbeddedConnectionProvider</classN ame> </connectionProvider> file:///F:/Program%20Files/Wildfire/conf/openfire.xml#

<ldap>

<host>taplansvr</host>

<port>389</port>

<baseDN>ou=SBSUsers;ou=Users;ou=MyBusiness;dc=TapLan;dc=Local</baseDN&g t;

<adminDN>taplan\administrator</adminDN>

<adminPassword>****</adminPassword>

<connectionPoolEnabled>true</connectionPoolEnabled>

<sslEnabled>false</sslEnabled>

<ldapDebugEnabled>false</ldapDebugEnabled>

<autoFollowReferrals>false</autoFollowReferrals>

<usernameField>sAMAccountName</usernameField>

<searchFilter>(objectClass=organizationalPerson)</searchFilter> file:///F:/Program%20Files/Wildfire/conf/openfire.xml#

<vcard-mapping> - <![CDATA[

&lt;vCard xmlns="vcard-temp"&gt;
  &lt;N&gt;
    &lt;GIVEN&gt;{cn}&lt;/GIVEN&gt;
  &lt;/N&gt;   &lt;EMAIL&gt;
    &lt;INTERNET/&gt;     &lt;USERID&gt;{mail}&lt;/USERID&gt;
  &lt;/EMAIL&gt;   &lt;FN&gt;{displayName}&lt;/FN&gt;   &lt;ADR&gt;
    &lt;HOME/&gt;     &lt;STREET&gt;{homePostalAddress}&lt;/STREET&gt;     &lt;PCODE&gt;{homeZip}&lt;/PCODE&gt;     &lt;CTRY&gt;{co}&lt;/CTRY&gt;
  &lt;/ADR&gt;   &lt;ADR&gt;
    &lt;WORK/&gt;     &lt;STREET&gt;{streetAddress}&lt;/STREET&gt;     &lt;LOCALITY&gt;{l}&lt;/LOCALITY&gt;     &lt;REGION&gt;{st}&lt;/REGION&gt;     &lt;PCODE&gt;{postalCode}&lt;/PCODE&gt;     &lt;CTRY&gt;{co}&lt;/CTRY&gt;
  &lt;/ADR&gt;   &lt;TEL&gt;
    &lt;HOME/&gt;     &lt;VOICE/&gt;     &lt;NUMBER&gt;{homePhone}&lt;/NUMBER&gt;
  &lt;/TEL&gt;   &lt;TEL&gt;
    &lt;HOME/&gt;     &lt;CELL/&gt;     &lt;NUMBER&gt;{mobile}&lt;/NUMBER&gt;
  &lt;/TEL&gt;   &lt;TEL&gt;
    &lt;WORK/&gt;     &lt;VOICE/&gt;     &lt;NUMBER&gt;{telephoneNumber}&lt;/NUMBER&gt;
  &lt;/TEL&gt;   &lt;TEL&gt;
    &lt;WORK/&gt;     &lt;CELL/&gt;     &lt;NUMBER&gt;{mobile}&lt;/NUMBER&gt;
  &lt;/TEL&gt;   &lt;TEL&gt;
    &lt;WORK/&gt;     &lt;FAX/&gt;     &lt;NUMBER&gt;{facsimileTelephoneNumber}&lt;/NUMBER&gt;
  &lt;/TEL&gt;   &lt;TEL&gt;
    &lt;WORK/&gt;     &lt;PAGER/&gt;     &lt;NUMBER&gt;{pager}&lt;/NUMBER&gt;
  &lt;/TEL&gt;   &lt;TITLE&gt;{title}&lt;/TITLE&gt;   &lt;ORG&gt;
    &lt;ORGUNIT&gt;{department}&lt;/ORGUNIT&gt;
  &lt;/ORG&gt;
&lt;/vCard&gt;

]]> </vcard-mapping>

<nameField>cn</nameField>

<emailField>mail</emailField>

<groupNameField>cn</groupNameField>

<groupMemberField>member</groupMemberField>

<groupDescriptionField>description</groupDescriptionField>

<posixMode>false</posixMode>

<groupSearchFilter>(objectClass=group)</groupSearchFilter>

</ldap> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <provider> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <vcard>

<className>org.jivesoftware.openfire.ldap.LdapVCardProvider</className& gt; </vcard> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <user> <className>org.jivesoftware.openfire.ldap.LdapUserProvider</className& gt; </user> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <auth> <className>org.jivesoftware.openfire.ldap.LdapAuthProvider</className& gt; </auth> file:///F:/Program%20Files/Wildfire/conf/openfire.xml# <group> <className>org.jivesoftware.openfire.ldap.LdapGroupProvider</className > </group> </provider> <setup>true</setup> </jive>

You need to share the group in the Openfire server, for it to autopopulate to the Roster. Some other settings to consider:

  • Install subscription plugin

  • configure to Accept All

This will allow users to add other users to their roster with out requestion permission from the other user.

That sounds like a great solution. However I do not recall seeing a setting/ option for that anywhere. Would you mind detailing where that is at?

~Ben

Errr, wow… tabs along the top. 10 points.

~Ben

Login to your Openfire admin interface. Go to plugins, then available plugins. Install the subscription plugin. Go back to the Server tab and choose the Subscription Properties. Configure as previously stated.

To share a group goto the Users/Groups tab. Click Group Summary. Find the group you wish to share. Click it. Then enable contact list group sharing. Share with all users (may be redundant if everyone is in it).