powered by Jive Software

LDAP User Summary Slow to Display

I have a current installation of OpenFire 3.7.1 running on a Windows 2003 Server (32 Bit) with LDAP integration and MS SQL 2005 Express setup and working correctly.

I am setting up a new installation (3.8.2) on a Windows 2008 R2 Server (same domain) and integrating it into the same LDAP (Active Directory) database with SQL Server 2008 R2 Express. After the setup was complete, I logged into the OpenFire Admin console and when I click on the Users/Groups tab, it takes approximately 5 minutes to display the users which the same process takes only 2 seconds on the Windows 2003 server.

I am not using LDAPS and I have LDAPConnectionPooling enabled.

Any Ideas and thanks…?

how are you connecting to the domain controller?

for host, are you using the root of your domain, or targetting a a single dc?

If your using the root of your domain…then try a single dc.

the windows 2003 install is installed directly on a domain controller.

the windows 2008 install is also installed directly on a domain controller.

my ldap.host is the local controller (single dc).

Got it working…

Uninstalled 3.8.2 and deleted the SQL Database. Installed 3.7.1 and created a new blank database from script. Configured all settings to connect via ldap. Tested install and LDAP User query worked as expected. Upgraded to 3.8.2 and all is still working.

Thanks for looking at it though…

What’s going on with OpenFire 3.8.2 and LDAP? I do have an clean new setup, configured LDAP to an Active Directory with ~ 15.000 people and about the same amount of groups and surprise… cliking on /user-summary.jsp does never end.

I’m with the same problem. I’ve already tried to find help in another two posts: http://community.igniterealtime.org/thread/43874 and http://community.igniterealtime.org/message/233876

Today I tried again…

Withou SSL (389) and with ldap.autoFollowReferrals and ldap.connectionPoolEnabled seted to ‘false’ worked just fine!

Cheers!